Questions tagged [compilation]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
0 votes
1 answer
15 views

no method named `as_fd` found for struct `Async` in the current scope

I am compiling my node with the substrate release branch as polkadot-v0.9.22 and I get the following errors. What is this error and how do I even fix this? error[E0599]: no method named `as_fd` found ...
RRR's user avatar
  • 43
0 votes
0 answers
28 views

Custom RPC Error on sp_api::decl_runtime_apis!

We are adding a custom rpc and following along with https://github.com/AlexD10S/susbtrate-node-template/blob/rpc-custom-methods/pallets/template/rpc/runtime-api/src/lib.rs and https://github.com/...
donkeydonkey's user avatar
0 votes
0 answers
18 views

How do i run ```npx @727-ventures/typechain-compiler --config typechain.config.json``` for a nightly version

So i am running this command npx @727-ventures/typechain-compiler --config typechain.config.json to get to compile so i can write my test file for my contracts and use the typechain gotten. This is ...
Mite's user avatar
  • 21
3 votes
1 answer
246 views

Build fails: protoc failed: bitswap.v1.2.0.proto: No such file or directory

When building a Substrate-project, I receive the following error: protoc failed: bitswap.v1.2.0.proto: No such file or directory
sea212's user avatar
  • 539
3 votes
1 answer
98 views

Persistent overuse of system resources by rust-analyzer

After limiting the number jobs in order to handle the amount of resources used by rust-analyzer it keeps using all cores so my computer ends up hanged out: In addition, I've noticed that several ...
magecnion's user avatar
  • 222
2 votes
1 answer
47 views

Why does compiling substrate require nightly toolchain?

rustup target add wasm32-unknown-unknown --toolchain nightly Why can't the stable toolchain be used to compile, what I beleive is the runtime to WASM? Why is nightly needed?
b0zero's user avatar
  • 533
3 votes
0 answers
230 views

Compilation error. unresolved windows_sys::Win32::Foundation

I'm on Windows 11, (intel core i7-9700K processor) and have stable-x86_64-pc-windows-msvc (default), rustc 1.67.1 (d5a82bbd2 2023-02-07) and cargo 1.67.1 (8ecd4f20a 2023-01-10) When I'm compiling some ...
Conor D'Arcy's user avatar
0 votes
2 answers
35 views

Why does building the parachain template build the polkadot and kusama runtime?

This is on my screen as I compile the substrate parachain template: Building: kusama-runtime(build), polkadot-runtime(build), parachain-template-runtime(build) ...
b0zero's user avatar
  • 533
0 votes
1 answer
78 views

A build problem when I build the substrate-node-template in windows10 system

I have searching some solutions in the internet. However, I can't deal with my problem. I hope someone can help me to deal with this problem. Thank you very much.
zitai wu's user avatar
3 votes
1 answer
308 views

build failed with substrate chain on rocksdb in linux

I followed this tutorial https://docs.substrate.io/tutorials/get-started/build-local-blockchain/. I got the below error when run cargo build --release. How can I fix it? cargo build -v --release ...
kayvan jam's user avatar
1 vote
0 answers
41 views

Substrate Node compiles, but does not run

When i run my substrate based node, i get Error: Service(Client(VersionInvalid("host doesn't provide any imports from non-env module: __wbindgen_placeholder__:__wbindgen_describe"))).
Joshua Aruokhai's user avatar
1 vote
1 answer
430 views

"Rust WASM toolchain not installed" with v0.9.25

I recently upgraded a fork of the Node Template to v0.9.25 and now I am getting an error about the Wasm toolchain not being installed. Per the official Substrate documentation, the failing build is ...
Dan Forbes's user avatar
1 vote
2 answers
498 views

Bulding polkadot (release-v0.9.24) fails while compiling a dependency (prost-build v0.10.4)

I'm trying to build Polkadot as a relay chain for a tutorial but compiling one of its dependencies fails! I may be missing some tools. Could you help? Platform: MacOS (Intel) Compiling prost-build v0....
stano's user avatar
  • 238
1 vote
1 answer
166 views

Substrate Node v3.0 getrandom Compilation error

The error described below is produced when attempting to compile the node upgraded to v3. The Cargo.toml files indeed specify the js feature; the issue occurs when compiling packages within Cargo.lock,...
Raid Ateir's user avatar
1 vote
3 answers
67 views

Computer freezes when compiling substrate

I am trying to run all of the tests in the substrate codebase. When the pc gets to the 1670th dependency it freezes. All of my RAM is being used and the pc won't respond. I have 16GB of RAM, Ryzen 5 ...
Szegoo's user avatar
  • 657
3 votes
1 answer
95 views

Cannot find TryInto (compilation error) after it was pruned from prelude

This Substrate PR removed TryInto from the sp_std's prelude: https://github.com/paritytech/substrate/pull/11136 While attempting to update to v0.9.19, which includes this PR, I am encountering this ...
notlesh's user avatar
  • 123
-3 votes
1 answer
135 views

Unable to compile Substrate v0.9.17 on Rust v1.60.0 [closed]

I am not able to compile Substrate v0.9.17 on Rust version 1.60.0 stable. I am getting the following compilation error. It was working before I did rustup update. I missed recording which Rust version ...
Gautham J's user avatar
  • 116
4 votes
2 answers
197 views

std in conditional compilation [closed]

#![cfg_attr(not(feature = "std"), no_std)] Does the "std" above reflect the rust standard library or the std feature defined in the cargo.toml for a given crate? Also, for many of ...
infinitesimallySmart's user avatar
7 votes
2 answers
442 views

How to use sp_core in libraries that target wasm for the web

I'm playing around with some front end utilities where Substrate libraries like sp_core would be useful, but I'm getting the following error on compilation. error: failed to run custom build command ...
Bread's user avatar
  • 95
7 votes
2 answers
94 views

How do I distribute the compiled node binary to peers?

What's the way to distribute the compiled node binary to peers, so that they wouldn't need to build everything from scratch on their virtual machines? I'm asking this because building everything takes ...
Ilya Tegmark's user avatar
5 votes
1 answer
153 views

Cannot find macro `vec` in this scope when using pallet-staking

I am trying to implement the prebuilt pallet-staking using 4.0.0-dev and tag devhub/latest. I am getting a compilation error on npos-elections. Should I be able to add the staking pallet into the ...
Max's user avatar
  • 305