Skip to main content

Questions tagged [compile]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
0 votes
1 answer
17 views

no method named `as_fd` found for struct `Async` in the current scope

I am compiling my node with the substrate release branch as polkadot-v0.9.22 and I get the following errors. What is this error and how do I even fix this? error[E0599]: no method named `as_fd` found ...
RRR's user avatar
  • 43
0 votes
1 answer
56 views

Compile Error in vandersnatch_vrfs crate in SDK version 1.3.0

I'm trying to update my node from SDK version 1.2.0 to 1.3.0. To do so I make this change to each package in my Cargo.toml: - sp-core = { tag = "polkadot-v1.2.0", git = "https://github....
JoshOrndorff's user avatar
  • 1,201
0 votes
1 answer
46 views

getting error while building substrate blockchain?

I have cloned polkadot-sdk version 1.1.0. When I try to build binary it is throwing error. Can you please tell why I am getting error as I have not changed anything in codebase yet. rust versions ...
Karanvir Singh's user avatar
2 votes
2 answers
51 views

How to compile polkadot node with only rococo runtime

When I build polkadot with cargo build --release it builds all the runtimes including Polkadot, Kusama, Rococo, Westend. This is a lot to compile and most of it is not needed. In my case, I'm testing ...
JoshOrndorff's user avatar
  • 1,201
2 votes
2 answers
2k views

how to resolve? error[E0422]: cannot find struct, variant or union type `LineColumn` in crate `proc_macro`

error[E0422]: cannot find struct, variant or union type `LineColumn` in crate `proc_macro` --> /home/wangchao/.cargo/registry/src/mirrors.ustc.edu.cn-61ef6e0cd06fb9b8/proc-macro2-1.0.56/src/...
user4415's user avatar
6 votes
1 answer
264 views

Compilation Errors on Template Node

We are on arch linux and have been compiling the substrate node template just fine. Then with a recent rolling update of the OS we cannot compile the substrate template node. Some warnings about wasm-...
donkeydonkey's user avatar
0 votes
1 answer
78 views

Could not find `Cargo.lock`

I'm using cross to build my node. And I got this: warning: Could not find `Cargo.lock` for `/root/code/darwinia-network/darwinia-2.0/runtime/pangolin/Cargo.toml`, while searching from `/target/x86_64-...
AurevoirXavier's user avatar
  • 10.6k