Questions tagged [error]

Questions relating to troubleshooting specific errors.

Filter by
Sorted by
Tagged with
0 votes
1 answer
32 views

Error: 'tikv-jemalloc-sys v0.4.3+5.2.1-patched.2' fails to build after upgrading substrate-based chain to polkadot-v0.9.22 on WSL2

After upgrading our chain and its relevant dependencies to polkadot-v0.9.22 I am getting the following build error for 'tikv-jemalloc-sys v0.4.3+5.2.1-patched.2' I have also tried to add parity-util-...
user avatar
0 votes
0 answers
14 views

Exported method `TryRuntime_on_runtime_upgrade` is not found

cargo run --features try-runtime try-runtime \ --execution Native \ --chain dev \ on-runtime-upgrade \ live \ --uri ws://xxxxxxxx I implemented try-runtime according to the ...
user avatar
1 vote
1 answer
47 views

Node that was not modified fails to build

I had a fully functioning node that was built about 4 day ago and I was using it. Today I've decided to rebuild it with cargo build -r and for some reason if failed to build with absolutely weird ...
user avatar
  • 344
1 vote
1 answer
99 views

Pre-dispatch Error

I took a look at the check-weight SignedExtention to see what happens when a block is full. It appears that it returns an error InvalidTransaction::ExhaustsResources. It think it puts it back into the ...
user avatar
  • 273
1 vote
1 answer
26 views

False positive Errors on Jetbrains IDEs

I’m currently using VSCode to develop a chain based on Substrate, and want to switch to CLion or IntelliJ IDEA, but after setting up these IDEs, the inspection reports more than 90 errors in my ...
user avatar
0 votes
0 answers
32 views

Kitties tutorial - StorageValue error

I'm following the kitties tutorial p1 and I have some problems in the section "Add storage items". I replaced the ACTION line with this in pallet/kitties/src/lib.rs: #[pallet::storage] #[...
user avatar
  • 1
0 votes
0 answers
26 views

How to fix "DepositFailed" on orml_currencies while benchmarking?

I try to benchmark one extrinsic. I use the MultiReservableCurrency of orml_currencies. GetNativeCurrencyId is T::BaseAsset::get(). orml_currencies is T::Currencies. Consider the following in ...
user avatar
  • 33
0 votes
1 answer
42 views

Guide or Best practice for parachain Runtime Upgrade(Exception handle or rollback)!

The forkless runtime upgrade is an excellent feature! I have searched many documents on runtime upgrade, but no guide found for handling upgrade exceptions or rollback. The most exception often ...
user avatar
1 vote
1 answer
40 views

(FIXED) Substrate forkless upgrade tutorial: pallet_scheduler has breaking changes [closed]

(This question was originally asked here: https://stackoverflow.com/questions/72056703/substrate-forkless-upgrade-tutorial-pallet-scheduler-has-breaking-changes) I am following the Substrate forkless ...
user avatar
  • 227
3 votes
1 answer
31 views

Cannot find TryInto (compilation error) after it was pruned from prelude

This Substrate PR removed TryInto from the sp_std's prelude: https://github.com/paritytech/substrate/pull/11136 While attempting to update to v0.9.19, which includes this PR, I am encountering this ...
user avatar
  • 33
2 votes
1 answer
17 views

What does this validator error mean? "Validator with index 0 is disabled and should not be attempting to author blocks."

So this happened when I created a new validator and injected their session keys into my node. Then I proceeded to call forceNewEra from the staking module as sudo, and I am greeted with this : ...
user avatar
1 vote
3 answers
47 views

0x02000000 Being Returned in Extrinsic Receipt and Failing Error Module Indexing

When submitting a stake request through the Python substrate-interface library, the extrinsic receipt comes back with the following parameters: ({'Module': {'index': 6, 'error': '0x02000000'}}, {'...
user avatar
3 votes
1 answer
46 views

Runtime upgrade error: system.FailedToExtractRuntimeVersion

Our goal is to migrate pallet code to the newer Substrate version and keep the block history (since ~ august 2020). Old Substrate ver. (10.02.2021) -> New Substrate ver. (14.01.2022) For such ...
user avatar
  • 83
0 votes
1 answer
15 views

ERROR: balances.transferKeepAlive -32602: Invalid params: UnknownVersion

I am having this issue of an error when transacting on my custom Setheum substrate Node. ERROR: balances.transferKeepAlive -32602: Invalid params: UnknownVersion.. Does it have anything to do with ...
user avatar
1 vote
1 answer
39 views

Collator panicked at 'Storage root must match that calculated.'

We have a few collators for the Kintsugi parachain actively syncing and producing blocks when they suddenly fall-over due to the following error: Apr 02 21:06:00 ubuntu-s-2vcpu-4gb-amd-fra1-01 ...
user avatar
1 vote
1 answer
42 views

Runtime panic when peering with node:

I require some insight into how to troubleshoot the following runtime error which only occurs when I try to peer with my running node. Using substrate v3.0.0 monthly-10-2021 I should also add that if ...
user avatar
1 vote
1 answer
23 views

NewContractNotFunded Error after submitting a smart contract on BereSheet

I'm trying to upload the flipper contract to Beresheet (Edgeware testnet) but after submitting, I got this contract.NewContractNotFunded error and the extrinsic failed. I search the error on Google ...
user avatar