1

I recently upgraded a fork of the Node Template to v0.9.25 and now I am getting an error about the Wasm toolchain not being installed. Per the official Substrate documentation, the failing build is adding the Wasm target to the nightly toolchain.

~: rustup show
Default host: x86_64-unknown-linux-gnu
rustup home:  /home/werq/.rustup

installed toolchains
--------------------

stable-x86_64-unknown-linux-gnu (default)
nightly-x86_64-unknown-linux-gnu
1.60.0-x86_64-unknown-linux-gnu

installed targets for active toolchain
--------------------------------------

wasm32-unknown-unknown
x86_64-unknown-linux-gnu

active toolchain
----------------

stable-x86_64-unknown-linux-gnu (default)
rustc 1.62.0 (a8314ef7d 2022-06-27)
4
  • Something amiss with your setup...? github.com/substrate-developer-hub/substrate-node-template/runs/… for sure this built with the template for this version
    – Nuke
    Commented Jul 13, 2022 at 15:14
  • My setup has not changed - only the Substrate version changed and the build started failing. You can actually check out the set-up yourself by looking at the workflow configuration. I noticed that your build was passing, but I also noticed that it looks like that build is skipping Wasm compilation, which seems to be the root of my problem.
    – Dan Forbes
    Commented Jul 13, 2022 at 15:35
  • You probably dont want to build the runtime in the CI anyway? Then you can skip it with an env flag like for example here. Commented Jul 14, 2022 at 12:16
  • I have the same problem when I build locally and I definitely need the runtime ;-)
    – Dan Forbes
    Commented Jul 14, 2022 at 14:59

1 Answer 1

3

This was a transient problem that was fixed by updating my nightly version after a few days.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.