Skip to main content

Questions tagged [wsl]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
0 votes
2 answers
21 views

Unable to connect to polkadot node running on wsl to polkadot js app

I am running polkadot-sdk on wsl I start the node: ./target/release/polkadot --dev and then when I try connecting it to polkadotjs app on browser in windows it doesn't connect It just says - "...
Rishi's user avatar
  • 1
1 vote
1 answer
376 views

WSL - Substrate Node Template Compilation Error

GM, I installed the dependencies for WSL mentioned in the docs, but I am unable to compile the template node. Any tips? zach@DESKTOP-P2G1H4R:~/substrate/substrate-node-template$ cargo build --package ...
Crypdoughdoteth's user avatar
0 votes
0 answers
33 views

Compile errors building Substrate Recipes out of the box

I'm trying to get started with substrate by looking at Substrate Recipes. I installed rust using curl --proto '=https' --tlsv1.2 -sSf https://sh.rustup.rs | sh with WSL with default configuration (...
The Coding Wombat's user avatar
0 votes
1 answer
459 views

cannot create a memfd error with Ubuntu 20.04 on windows10 wsl1

follow the tutorial https://docs.substrate.io/tutorials/get-started/simulate-network/ ,when i running the following command: ./target/release/node-template \ --base-path /tmp/alice \ --chain local \ -...
littleyy's user avatar
3 votes
3 answers
911 views

Error: 'tikv-jemalloc-sys' fails to build after upgrading substrate-based chain on WSL2

After upgrading our chain and its relevant dependencies to polkadot-v0.9.22 I am getting the following build error for 'tikv-jemalloc-sys v0.4.3+5.2.1-patched.2' I have also tried to add parity-util-...
chexware's user avatar
  • 325
6 votes
1 answer
1k views

Error: failed to run custom build command for `tikv-jemalloc-sys v0.4.3+5.2.1-patched.2`

I was trying to build the substrate-node-template (https://docs.substrate.io/tutorials/v3/create-your-first-substrate-chain/) for the first time. I am using WSL2 with Ubuntu 22.04 LTS. I came to the ...
gmluqa's user avatar
  • 91
0 votes
0 answers
51 views

Substrate-node-template build fail for Ubuntu 20.04 on Windows 10 [duplicate]

I was following the beginner's tutorial here: https://docs.substrate.io/tutorials/v3/create-your-first-substrate-chain/ When I get to cargo build --release I get the following error: thread 'main' ...
rarara's user avatar
  • 141