3

Rococo is running on 0.9.18 but from Polkadot js UI, it looks like Kusama is still running on 0.9.17.

enter image description here

I am preparing for Kusama deployment. Can someone please point me to the right JSON file for Kusama?

I am using this https://github.com/paritytech/polkadot/blob/v0.9.18/node/service/res/kusama.json

and getting below error log

("Exported method ParachainHost_session_index_for_child is not found"))) }
2022-03-24 16:43:00 [Relaychain] Our view contains 0xb0a8…dafe but the overseer never told use we should work on this added=0xb0a8…dafe
2022-03-24 16:43:00 [Relaychain] error=RollingSessionWindow(SessionsUnavailable { kind: RuntimeApi(Execution { runtime_api_name: "session_index_for_child", source: Application(Execution(Other("Exported method ParachainHost_session_index_for_child is not found"))) }), info: None })
2022-03-24 16:43:00 [Relaychain] error=Sender(Runtime(RuntimeRequest(Execution { runtime_api_name: "session_index_for_child", source: Application(Execution(Other("Exported method ParachainHost_session_index_for_child is not found"))) }))) ctx="on FromOverseer"
2022-03-24 16:43:00 [Relaychain] Failed to fetch runtime API data for job err=Execution { runtime_api_name: "validator_groups", source: Application(Execution(Other("Exported method ParachainHost_validator_groups is not found"))) }
2022-03-24 16:43:00 [Relaychain] job finished with an error job="bitfield-signing-job" parent_hash=0xb0a8…dafe err=Util(RuntimeApi(Execution { runtime_api_name: "session_index_for_child", source: Application(Execution(Other("Exported method ParachainHost_session_index_for_child is not found"))) }))
2022-03-24 16:43:01 [Relaychain] 🔍 Discovered new external address for our node: /ip4/223.233.73.39/tcp/30333/ws/p2p/12D3KooWJx2Xi1wQsSQ3rX2hD21zahPij7ZXfi9qL48jDayh5zka    
2022-03-24 16:43:02 [Relaychain] Received msg before first active leaves update. This is not expected - message will be dropped. msg=ActiveDisputes(Sender { complete: false })
2022-03-24 16:43:02 [Relaychain] error=Sender(AskActiveDisputesCanceled) ctx="on FromOverseer"
2022-03-24 16:43:05 [Relaychain] ⚙️  Syncing, target=#11947262 (24 peers), best: #7354 (0x49f4…d985), finalized #7170 (0xdfce…7dbf), ⬇ 613.7kiB/s ⬆ 44.4kiB/s    
2022-03-24 16:43:05 [Parachain] 💤 Idle (0 peers), best: #0 (0x20d8…b055), finalized #0 (0x20d8…b055), ⬇ 0 ⬆ 0    
2022-03-24 16:43:10 [Relaychain] ⚙️  Syncing 1338.4 bps, target=#11947263 (25 peers), best: #14046 (0xd40d…9a2d), finalized #13824 (0xb224…3695), ⬇ 736.2kiB/s ⬆ 22.8kiB/s    
2022-03-24 16:43:10 [Parachain] 💤 Idle (0 peers), best: #0 (0x20d8…b055), finalized #0 (0x20d8…b055), ⬇ 0 ⬆ 0    
2022-03-24 16:43:15 [Relaychain] ⚙️  Syncing 1798.4 bps, target=#11947264 (25 peers), best: #23040 (0x08df…e908), finalized #22528 (0xd31f…1eb2), ⬇ 557.7kiB/s ⬆ 22.5kiB/s    

However its syncing with Kusama and showing correct block count. Should I ignore above error message?

I also want to mention that I just integrated my parachain with Rococo successfully with Polkadot 0.9.18.

1
  • 1
    Looks like you have a few questions here. I answered your first question - not sure about the error message though - maybe someone else can help there.
    – Bruno
    Mar 24, 2022 at 11:53

1 Answer 1

2

Looks like it will be upgraded to 0.9.18 soon:

Some nodes may have already upgraded the node itself (upper right is node version) but you can see that the runtime is 0.9.17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.