Questions tagged [runtime-upgrade]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
12 votes
2 answers
300 views

What is the proper way of executing a runtime upgrade on a parachain?

I would like to upgrade my parachain. What is the proper way of executing a runtime upgrade on a parachain? Which RPC method to call? Should this be applied to collators or rpc-nodes?
Alex's user avatar
  • 294
8 votes
1 answer
296 views

How would someone go without the SUDO pallet?

I've seen in multiple online networks(chains) that they do not use the pallet sudo. We're trying to figure out how to take the pallet out of our network in order to leave everything to Governance. For ...
Charalampos Mitrodimas's user avatar
8 votes
1 answer
97 views

Why is the Rococo `maxCodeSize` too small to do adequate incremental runtime upgrades? [closed]

If we want to connect a parachain to Rococo's 'rococo-local' relay chain we follow this Cumulus tutorial using polkadot-launch. Part of the pre-launch steps mentioned here is to minimize your runtime ...
Luke Schoen's user avatar
  • 2,312
7 votes
1 answer
90 views

Unstuck non-upgraded Parachain

A parachain had an upgrade schedule on a relay chain, but the upgrade did not go through, forcing the parachain to stop producing blocks. I tried forcing a new validationCode using SUDO, but that did ...
Santiago Balaguer's user avatar
7 votes
1 answer
60 views

Backward compatible changes in the runtime

If I add a new field to a struct that is not stored in storage but used as a parameter to an extrinsic, will it break decoding if a node with the changed runtime is syncing (i.e. executing older ...
Nahu's user avatar
  • 337
7 votes
2 answers
121 views

How to identify node update storage migrations?

I am working on Substrate-based node upgrades. I stick to Polkadot releases and start from polkadot-v0.8.25 to the latest versions. While upgrading I need to make sure that I don’t miss any storage ...
Maksim Ramanenkau's user avatar
6 votes
1 answer
113 views

When are you required to change the `authoring_version` for forkless runtime upgrades?

In the Substrate documentation here and the Substrate reference documentation here it says the authoring_version "is the version of the authorship interface. An authoring node will not attempt to ...
Luke Schoen's user avatar
  • 2,312
6 votes
1 answer
56 views

Is it clear what is behind the block time slow down we're seeing in Kusama Parachains, and how close is it to being solved?

We've seen a significant slow down of block time on Kusama. It seems that this may be related to the deployment od client v0.9.16. It is clear what is behind the slow down? If so, how close are we to ...
Matt Moroz's user avatar
6 votes
2 answers
129 views

best practice to test a runtime with large chain state before runtime upgrade?

As the chain state goes larger and larger, it gets hard to export/fetch the chain state. Are there any other tools aside from fork-off-substrate and try-runtime for performing a runtime migration?
AurevoirXavier's user avatar
5 votes
1 answer
78 views

What is the Incomplete Execution error on parachain upgrade?

I have been upgrading my parachain many times over the last few days with no issue at all. I have been using Polkadotjs Apps for this also running on my local machine. My process is that I use the ...
T9b's user avatar
  • 456
5 votes
1 answer
148 views

How to make a parachain runtime upgrade

I´m trying to make a parachain runtime upgrade without a migration, as a way to understand the process before trying with a migration. I´m using version 0.9.40 of polkadot for the relay chain and the ...
Xavier's user avatar
  • 405
5 votes
2 answers
420 views

Storage Migration Guide Using #[pallet::storage]

I am new to both substrate and rust so trying to educate myself. I've the read documentation for both and am now going through the various tutorials and guides. I'm currently on the Basic Storage ...
jpataylor's user avatar
  • 321
5 votes
1 answer
112 views

After doing runtime upgrade getting contract not found in substrate contracts ui

I am doing runtime upgrade of substrate blockchain from 0.9.36 --> 0.9.37 --->0.9.43 . And i have some contracts deployed on the running blockchain which is running on 36 version . After doing ...
Karanvir Singh's user avatar
5 votes
2 answers
171 views

Runtime Upgrade: Transaction exhaust block limits

I usually use scheduler to upgrade my runtime and it was working fine until now. I have Transaction exhaust block limits trying to upgrade live chain. I build the wasm using srtool v0.9.19, and the ...
Daniel Lam's user avatar
4 votes
1 answer
176 views

Adding pallet-gilt to a running chain breaks the chain

I am running a simple 2-validator substrate chain with my own keys (https://github.com/paritytech/substrate, branch = polkadot-v0.9.27). I have removed pallet-gilt from the runtime and what I am ...
Zycon's user avatar
  • 63
4 votes
1 answer
113 views

How to cancel or delay a scheduled parachain runtime upgrade?

I would like to know if there is a way to cancel or delay a runtime upgrade already scheduled by a parachain with the relay chain soon about to send the upgrade_go_ahead_signal. It is fairly easy to ...
Shoeb Siddiqui's user avatar
4 votes
1 answer
119 views

Unable to sync after runtime upgrade

After performing an upgrade on a remote node that includes a new pallet in my runtime, I attempted to sync a local node with the remote one, but I encountered the following error: Bootnode with peer ...
magecnion's user avatar
  • 200
4 votes
1 answer
103 views

Failed to do runtime upgrade: FailedToExtractRuntimeVersion

When trying to migrate the runtime from a very early version of substrate 3 (aug 2021) to polkadot 0.9.18 we are getting the following error: Failed to extract the runtime version from the new ...
Dylan Verstraete's user avatar
4 votes
1 answer
89 views

How to perform Parachain Runtime Upgrade via Democracy using Chopsticks

I am trying to perform a runtime upgrade using Acala's Chopsticks. I used this command: npx @acala-network/chopsticks@latest xcm -r ./configs/polkadot.yml -p ./configs/my_config.yml I followed the ...
Jitterbug's user avatar
  • 219
3 votes
2 answers
189 views

What could happen if the `BlockWeights` is set HIGHER than `MILLISECS_PER_BLOCK` (block time)?

In Substrate docs, it's said: "The maximum block weight should be equivalent to one-third of the target block time, allocating one third for block construction, one third for network propagation, ...
afm's user avatar
  • 355
3 votes
1 answer
112 views

How do I upgrade my node's RPC?

Following along the Substrate's Forkless Upgrades guide. I can upgrade the runtime but I can't figure it out how to upgrade my pallet's RPC. I have commented the below code for testing purposes and ...
Burak's user avatar
  • 903
3 votes
2 answers
102 views

I'm getting some issue during storage migration

I'm trying to trigger the storage migration on polkadot UI for our parachain. I'm trying different types to do this but getting some issues: Type 1 : If I simply upload the wasm file from sudo > ...
Deepak Chaudhary's user avatar
3 votes
1 answer
71 views

Runtime upgrade for `ParachainSystem::HostConfiguration`

When testing my runtime upgrade from polkadot_v1.0.0 to 1.5.0 with try-runtime I get this error from try-runtime [2024-02-06T14:50:51Z ERROR runtime::executive] - 0. error: Failed to decode storage ...
Simson's user avatar
  • 1,166
3 votes
2 answers
109 views

Runtime upgrade error: parachainSystem.ValidationDataNotAvailable

Follow this doc: https://docs.substrate.io/tutorials/v3/forkless-upgrades/#upgrade-the-runtime-1. Scheduled and set_code show an error: ValidationDataNotAvailable. Do I miss something? How to fix this ...
Bart Yang's user avatar
3 votes
1 answer
254 views

RPC node encounter `Cannot create a runtime error=Other(\"runtime requires function imports which are not present on the host:` after upgrade

I got a problem with upgrading my chain I've upgraded my chain from version A (Client+runtime) to version B (Client+runtime). I remove some host functions in client version B because runtime version B ...
Daniel Lam's user avatar
3 votes
1 answer
76 views

error[E0405]: cannot find trait `Signature` in crate `signature`

I am currently upgrading our chain to polkadot-v0.9.38 but when I run the build I get the following error: error[E0405]: cannot find trait `Signature` in crate `signature` --> /home/albrayanov/....
chexware's user avatar
  • 325
3 votes
3 answers
672 views

1010: Invalid Transaction: Transaction has a bad signature

I am getting this error on the block explorer "Extrinsics" tab the moment I add a debug related code into a Hello pallet into the node-template repo. E.g: #[pallet::call_index(0)] #[pallet::...
abhi3700's user avatar
  • 131
3 votes
1 answer
40 views

Must I migrate storage during upgrade if it uses an enum that has a new element?

So the question is quite simple. Let's say I have an original definition of nested enums like so: #[derive(MaxEncodedLen, Debug, Encode, Decode, Copy, Clone, Eq, PartialEq, TypeInfo)] pub enum ...
T9b's user avatar
  • 456
3 votes
1 answer
93 views

Is there a way to add a pallet with genesis config through a runtime upgrade?

I have a chain running with some pallets in the runtime. Now I want to add a new (already existing) pallet in the runtime, but this pallet has some genesis config entries. Is it possible to add this ...
Gautam D's user avatar
3 votes
1 answer
51 views

How does frequent updates to polkadot affect the operation of the polkadot chain itself?

I understand the concept of forkless updates, in that the code of the runtime is stored on the chain itself, and a runtime upgrade would entail updating this storage value on the chain. But looking at ...
Purple_Turtle's user avatar
3 votes
1 answer
136 views

Runtime upgrade error: system.FailedToExtractRuntimeVersion

Our goal is to migrate pallet code to the newer Substrate version and keep the block history (since ~ august 2020). Old Substrate ver. (10.02.2021) -> New Substrate ver. (14.01.2022) For such ...
vovacha's user avatar
  • 148
3 votes
1 answer
80 views

What needs to be done to change the consensus from POA to POS through a runtime upgrade?

Currently my chain(solo-chain) is on production which is working on POA. Now I have integrated the staking pallet after then when i am going to upgrade that code in the old prod chain by runtime ...
Pankaj's user avatar
  • 2,051
3 votes
1 answer
123 views

Upgrade parachain without sudo

I have a parachain with no sudo pallet. However, in order to perform an upgrade, the first step authorize requires Root origin. As a workaround, I have tried to run ForceScheduleCodeUpgrade from the ...
magecnion's user avatar
  • 200
3 votes
1 answer
62 views

Error upgrading parachain on Kusama: `parachainSystem.ProhibitedByPolkadot`

As a sudo of a parachain on Kusama, I am making the first runtime upgrade. Initially, I made the upgrade as a sudo unchecked weight and setCode without checks. The transaction looked successful it ...
Ramsey - Decentration's user avatar
3 votes
1 answer
77 views

Exported method `TryRuntime_on_runtime_upgrade` is not found

cargo run --features try-runtime try-runtime \ --execution Native \ --chain dev \ on-runtime-upgrade \ live \ --uri ws://xxxxxxxx I implemented try-runtime according to the ...
junyuan wei's user avatar
3 votes
1 answer
115 views

Update Substrate node from v2.0.1 to v3.0.0 in live network

I am updating the Substrate node from v2.0.1 to v3.0.0 in live network*. The initial plan was to merge the v3 code by following the official guidelines, build the new wasm and use a forkless runtime ...
Andrei Navoichyk's user avatar
3 votes
0 answers
60 views

Costs and Payment for Runtime Upgrades in Parachains

I'm currently working with Substrate parachains and have question that I'm hoping to get clarity on: Payment for Runtime Upgrade Execution: In a parachain context, when a runtime upgrade (an extrinsic)...
ALeSD's user avatar
  • 479
3 votes
0 answers
105 views

Troubleshooting Persistent Error Following Parachain Runtime Upgrade Despite Code Modification

We recently attempted a runtime upgrade on our parachain testnet (wss://moonbeam-integration-parachain.polkadex.trade) and made some modifications to the validate_unsigned code, specifically ...
ZKT's user avatar
  • 113
3 votes
0 answers
50 views

How do i upgrade the council through a runtime Upgrade?

I have written code for a storage migration but unfortunately the council members are not displaying after the runtime upgrade. Below is the code I wrote for the storage migration const COUNCIL_PREFIX:...
master chief's user avatar
3 votes
0 answers
58 views

Forkless upgrade from v0.9.16 to v0.9.17 fails

I am working on a Substrate node update. I have a node from Substrate repository that runs on v0.9.16. When I am executing forkless upgrade to v0.9.17 via polkadot apps (v0.121.2-89-x) it fails and I ...
Andrei Navoichyk's user avatar
3 votes
1 answer
174 views

Export state of a running chain and run it as alice

Hello everyone, I'm trying to spin up a test chain(with imported real chain data) with alice(so I can start it from genesis and start producing blocks with --alice flag) and after dumping the state of ...
flipchan's user avatar
  • 369
3 votes
0 answers
117 views

Why isn't our Runtime updating with `set_code`

We've gone through the tutorial for running upgrades. We've been able to successfully upgrade using the Polkadot UI. However, when we do the same thing with our custom Runtime, although the tx says it'...
Mitchell Turner's user avatar
2 votes
2 answers
194 views

Debug corrupted on dev update

We are performing upgrade on a chain, in the dev side just to ensure all is OK we do step by step using a forked state of the live chain, we got corrupted state log which we want to debug in order to ...
Dubs's user avatar
  • 294
2 votes
2 answers
144 views

Is it possible to integrate node-authorization pallet after genesis?

In the Permissioned Network tutorial on Substrate docs, it's shown how to created a permissioned network from scratch along with the node-authorization pallet to manage the validator set. However, in ...
afm's user avatar
  • 355
2 votes
2 answers
118 views

Ethereum chain as a Substrate chain

Is it technically possible to upgrade Ethereum to be Substrate compatible blockchain? I understand there is likely to be strong resistance toward such idea in ETH community but I am interested only ...
jangorecki's user avatar
2 votes
1 answer
197 views

How to upgrade the client?

I want to do a runtime upgrade but I got the same error as here solution is :- If there are changes not only to the runtime but also to the node, then this issue is normally caused by upgrading the ...
Wakar Seraj Khan's user avatar
2 votes
2 answers
58 views

Steps for migration from polkadot-v0.9.30 to polkadot-v0.9.43/v1.0.0

At Ternoa we are trying to do a long jump from polkadot-v0.9.30 to polkadot-v0.9.43 or the latest. We would like to get some suggestions here if someone or some projects already experienced this much ...
Immanuel John's user avatar
2 votes
1 answer
54 views

when will `‘Balances::transfer' will be removed` take into effect on main-net?

In this link Balances::transfer will be removed it say 'transfer' is deprecated. I have experienced this change on test-net and fixed my Dapp after got failure report. But when does it take into ...
breeze wang's user avatar
2 votes
1 answer
43 views

How to hardcode few AccountIds to a storage in migration?

During a storage migration I want to add few SS58 Address in one storage. How to hardcode it in migration script?
Immanuel John's user avatar
2 votes
1 answer
48 views

Is migration required after adding an extra storage map to a pallet

From my understanding how the runtime store its state adding an extra storage variable like pub Verified (get fn is_verified): map hasher(blake2_128_concat) us64 => (); to a pallet that already ...
mr_bovo's user avatar
  • 171