Questions tagged [epoch]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
1 vote
0 answers

After skipping epoch, not able to perform any extrinsic

I bump into Session changes on reversion question and tried out the solution given by @bkchr, there was no unexpected epoch change error after an epoch is skipped due to finalisation getting stopped. ...
Shubham Gupta's user avatar
3 votes
1 answer

What happens in epoch of a blockchain?

I have been working on a substrate blockchain. I want to know about the events and process happening in each epoch of blockchain and what are the concepts behind the epoch?
Karanvir Singh's user avatar
2 votes
0 answers

Switching from Aura to Babe - 'Current state of blockchain has invalid authorities set'

I'm attempting to switch a node from using Aura to Babe by copying the usage of Babe in some public chains. However when I run multiple nodes together I get the error: Unable to fetch auxiliary data ...
Jonathan Gray's user avatar
2 votes
0 answers

About MR for the "Import failed: Unexpected epoch change"

I saw the epoch issue is solved by this MR. However, it didn't work when I tried to test that on my local machine. Do I do something wrong? The steps are like this Two validators on my local machine ...
Jay Pan's user avatar
  • 65
4 votes
1 answer

Error with block built on XXX: Import failed: Unexpected epoch change

I'm trying to prepare a local parachain testnet. However, when I run two nodes at the same time, although the two nodes recognise each other no new blocks are added and I get this error: Error with ...
Darian Foulds's user avatar
7 votes
1 answer

The purpose of epochs in staking

What problem do epochs in staking solve? Why don't stakers win stakes by something as simple as generating data from history + the latest block (so that precomputing stakes is not possible), and then ...
The Quantum Physicist's user avatar
4 votes
1 answer

How get the starting Time of a an EraIndex?

I would like to have the start of an era by eraIndex like: const startingTime = getStartTimeOf( eraIndex ); Thank you.
Kami's user avatar
  • 537
2 votes
1 answer

SessionsPerEra doesn't seem to be affecting sessions per era

Am I fundamentally misunderstanding how staking handles election timings, please? I've been trying to change the number of eras in a session, to increase the number of elections for testing. I ...
JelliedOwl - Paul's user avatar