Linked Questions

4 votes
0 answers
186 views

How to solve this Failed to compact generated WASM binary.: Error(UnknownOpcode(192)) [duplicate]

For one assignment I have run the command cargo build --release so that I can build the pallet. After that I was getting the error After that according to this- Error Building Substrate contract Node(...
Nakul Agrawal's user avatar
0 votes
1 answer
133 views

Substrate-Node-Template does not start after cloning and renaming the template UnknownOpcode(192) [duplicate]

I recently ran into issues with working on my substrate-node-template. i had this issue as mentioned here: cannot run substrate on a fresh macbook m2 or here: Substrate Node Template does not start ...
amazing's user avatar
  • 63
0 votes
0 answers
84 views

Substrate Error [duplicate]

we create a local blockchain using substrate following this steps:- (https://docs.substrate.io/tutorials/get-started/build-local-blockchain/) upto cargo build --release steps is completed.then i using ...
support's user avatar
  • 135
2 votes
1 answer
422 views

Substrate Node Template does not start

I followed the tutorial on https://docs.substrate.io/tutorials/build-a-blockchain/build-local-blockchain/ exactly, but after building the node template (https://github.com/substrate-developer-hub/...
Tadeo's user avatar
  • 61
5 votes
1 answer
282 views

(Parachain) cannot create a runtime error=Other("cannot deserialize module: unknown Opcode(192)")

I was following the substrate SDK official documentation for building a parachain on the Polkadot blockchain, and in the connect a local parachain tutorial(https://docs.substrate.io/tutorials/build-a-...
Akansha Banerjee's user avatar
3 votes
1 answer
164 views

Encoded error while performing a storage migration

This is my first time migrating data, and I'd like to receive general guidance about what steps and command lines I need to use. I've been working with the node-template before to implement it in my ...
Didier M's user avatar
2 votes
1 answer
75 views

Zombienet error running polkadot v0.9.37

I'm using zombienet 1.3.43 and I built the Polkadot binary locally. I'm using macbook pro M1. config.toml: [settings] timeout = 1000 [relaychain] default_command = "./bin/polkadot" ...
Ruben G's user avatar
  • 333
3 votes
2 answers
91 views

Enable to build substrate node template on M2

The following error msg is given out error: failed to run custom build command for `tikv-jemalloc-sys v0.5.3+5.3.0-patched` Clang version Apple clang version 14.0.0 (clang-1400.0.29.202) Target: ...
Nakul Amate's user avatar
2 votes
1 answer
72 views

How do i verify i have the correct version of substrate binaries and libraries as required by substrate-parachain-template?

How do I verify I have the correct version of substrate binaries and libraries as required by substrate-parachain-template, and How do I write a rust-toolchain.toml file that matches the versions ...
Akansha Banerjee's user avatar
3 votes
2 answers
50 views

Substate node not compiling on Archlinux

Recently anytime i try to run substrate-node i get this error message, all attempts to update packages hasn't been helpful Error: Service(Client(VersionInvalid("cannot deserialize module: ...
Abimbola Adebayo's user avatar
2 votes
0 answers
40 views

wasm compilation for later rust versions

I am running a parachain on Ubuntu 22.04 jammy. where i am using polkadot 9.43. I see that in release notes it is said that nightly-2023-05-22 was tested for this substrate version https://github.com/...
cocokick's user avatar
  • 165