0

When I am doing runtime-upgrade from polkadot-v0.9.38 to polkadot-v0.9.39 .I am getting one issue of smart contract in my terminal

  2023-09-18 11:36:25 Corrupted state at `[67, 66, 25, 62, 73, 111, 171, 126, 197, 157, 97, 94, 208, 220, 85, 48, 6, 14, 153, 229, 55, 142, 86, 37, 55, 207, 59, 201, 131, 225, 123, 145, 7, 190, 185, 213, 63, 100, 190, 13, 84, 242, 53, 215, 14, 189, 128, 119, 55, 150, 202, 102, 150, 1, 58, 100, 98, 150, 229, 140, 171, 200, 50, 44, 7, 79, 42, 165, 176, 190, 50, 220]: Error { cause: Some(Error { cause: None, desc: "Not enough data to fill buffer" }), desc: "Could not decode `ContractInfo::storage_item_deposit`" }`    
2023-09-18 11:36:27 🙌 Starting consensus session on top of parent 0xd49263641146674ccb5c71c679

And I have some contracts deployed on the running blockchain which is running on 36 version . After doing runtime upgrade from 0.9.38---> 0.9.39 version . I tried to check contracts on my chain. When I tried to call them through substrate contracts-ui (on my chain which is now runtime upgraded to 39 version from 36 version) it is showing contracts not found and I am unable to call my deployed contracts .

2

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.