1

I am trying to run e2e tests but getting the following error. Example of running the e2e tests of the flipper contract:

running 4 tests
test flipper::tests::it_works ... ok
test flipper::tests::default_works ... ok
test flipper::e2e_tests::it_works ... FAILED
test flipper::e2e_tests::default_works ... FAILED

failures:

---- flipper::e2e_tests::it_works stdout ----
thread 'flipper::e2e_tests::it_works' panicked at /Users/sergejsakac/.cargo/registry/src/index.crates.io-6f17d22bba15001f/ink_e2e-4.3.0/src/xts.rs:294:13:
decoding ContractInstantiateResult failed: Could not decode `ContractResult::events`:
    Could not decode variant byte for `Option`:
        Not enough data to fill buffer


---- flipper::e2e_tests::default_works stdout ----
thread 'flipper::e2e_tests::default_works' panicked at /Users/sergejsakac/.cargo/registry/src/index.crates.io-6f17d22bba15001f/ink_e2e-4.3.0/src/xts.rs:294:13:
decoding ContractInstantiateResult failed: Could not decode `ContractResult::events`:
    Could not decode variant byte for `Option`:
        Not enough data to fill buffer

Rust version: rustc 1.74.0-nightly

Cargo contract version: cargo-contract-contract 3.2.0-unknown-aarch64-apple-darwin

The weird thing is that on my other Macbook, I have the same version of both rust and cargo contract, and the tests run successfully.

1
  • did you try with the latest stable? I guess nightly can be the problem here
    – kriko.eth
    Sep 5, 2023 at 11:44

1 Answer 1

1

It should work on rust v1.72 and substrate-contracts-node v0.31 with cargo-contract-contract 3.2

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.