0

I got this error while authorizing specific nodes in building a blockchain. It gives me error like this.

error: failed to select a version for `bounded-collections`.
    ... required by package `sp-core v21.0.0 (https://github.com/paritytech/substrate.git?branch=polkadot-v1.0.0#948fbd2f)`
    ... which satisfies git dependency `sp-core` of package `frame-benchmarking v4.0.0-dev (https://github.com/paritytech/substrate.git?branch=polkadot-v1.0.0#948fbd2f)`
    ... which satisfies git dependency `frame-benchmarking` of package `frame-system-benchmarking v4.0.0-dev (https://github.com/paritytech/substrate.git?branch=polkadot-v1.0.0#948fbd2f)`
    ... which satisfies git dependency `frame-system-benchmarking` of package `node-template-runtime v4.0.0-dev (/home/ubuntu/substrate-node-template/runtime)`
    ... which satisfies path dependency `node-template-runtime` (locked to 4.0.0-dev) of package `node-template v4.0.0-dev (/home/ubuntu/substrate-node-template/node)`
versions that meet the requirements `^0.1.8` are: 0.1.8

all possible versions conflict with previously selected packages.

  previously selected package `bounded-collections v0.1.6`
    ... which satisfies dependency `bounded-collections = "^0.1.4"` (locked to 0.1.6) of package `sp-core v7.0.0 (https://github.com/paritytech/substrate.git?branch=polkadot-v0.9.42#bca8a29d)`
    ... which satisfies git dependency `sp-core` (locked to 7.0.0) of package `frame-benchmarking v4.0.0-dev (https://github.com/paritytech/substrate.git?branch=polkadot-v0.9.42#bca8a29d)`
    ... which satisfies git dependency `frame-benchmarking` (locked to 4.0.0-dev) of package `frame-benchmarking-cli v4.0.0-dev (https://github.com/paritytech/substrate.git?branch=polkadot-v0.9.42#bca8a29d)`
    ... which satisfies git dependency `frame-benchmarking-cli` (locked to 4.0.0-dev) of package `node-template v4.0.0-dev (/home/ubuntu/substrate-node-template/node)`

failed to select a version for `bounded-collections` which could resolve this conflict
]

More logs here

3
  • What the exact command you are executing to get this error?
    – Alex Bean
    Aug 31, 2023 at 10:28
  • cargo check -p node-template-runtime --release
    – Preethi M
    Sep 6, 2023 at 12:17
  • I’m voting to close this question because it's outdated and lacks of details.
    – AurevoirXavier
    yesterday

1 Answer 1

0

There is something wrong with your dependencies versioning, more specifically sp-core (I see v0.9.42 & v1.0.0). Check your Cargo.toml files for your node, runtime and pallet(s).

Not the answer you're looking for? Browse other questions tagged or ask your own question.