1

I am getting the below error when I build and run substrate-parachain-template using zombienet. I am using the latest release (master branch of substate-parachain-template) which uses the latest substrate branch polkadot-v1.0.0. I was able to run a relay chain and parachain network successfully using the older branch polkadot-v0.9.43. But when I cloned the latest (master branch, which uses substrate branch polkadot-v1.0.0) I get the error below. I have also attached my Zombienet config after the error. This error only happens with branch v1.0.0 of substrate-parachain-template

Error:       Error: Command failed with exit code 1: bash -c binaries/parachain-template-node-v1.0.0 export-genesis-state --chain zn-db/template-rococo-1000-rococo-local.json > zn-db/cfg/genesis-state-1000 && binaries/parachain-template-node-v1.0.0 export-genesis-wasm --chain zn-db/template-rococo-1000-rococo-local.json > zn-db/cfg/genesis-wasm-1000
Error: Service(Client(Backend("IO error: While lock file: /Users/me/Library/Application Support/parachain-template-node-v1.0.0/chains/local_testnet/db/full/LOCK: Resource temporarily unavailable")))

I ran zombenet with this command

zombienet-macos -p native -d zn-db spawn ./zombienet-config.toml

Zomebienet config

[settings]
timeout = 1000

[relaychain]
default_command = "binaries/polkadot-v1.0.0"
default_args = [ "-lparachain=debug" ] 
chain = "rococo-local"

    [[relaychain.nodes]]
    name = "alice"
    validator = true
    ws_port = 9900

    [[relaychain.nodes]]
    name = "bob"
    validator = true

    [[relaychain.nodes]]
    name = "charlie"
    validator = true

    [[relaychain.nodes]]
    name = "dave"
    validator = true

[[parachains]]
id = 1000
cumulus_based = true
add_to_genesis = true
chain = "template-rococo"

    [parachains.collator]
    command = "binaries/parachain-template-node-v1.0.0"
    name = "parachain-A-1000-collator01"
    ws_port = 9910
    args = ["--log=xcm=trace,pallet-assets=trace"]

[[parachains]]
id = 1001
add_to_genesis = true
cumulus_based = true

    [parachains.collator]
    command = "binaries/parachain-template-node-v1.0.0"
    name = "parachain-B-1001-collator01"
    ws_port = 9920
    args = ["--log=xcm=trace,pallet-assets=trace"]


[types.Header]
number = "u64"
parent_hash = "Hash"
post_state = "Hash"


[[hrmp_channels]]
sender = 1000
recipient = 1001 
max_capacity = 8
max_message_size = 512

[[hrmp_channels]]
sender = 1001
recipient = 1000
max_capacity = 8
max_message_size = 512
3
  • Hi @Neo, can you please rm/mv this directory (/Users/me/Library/Application Support/parachain-template-node-v1.0.0/chains/local_testnet) and try again?
    – pepoviola
    Aug 8, 2023 at 23:23
  • @pepoviola I tried to do that, but found out that the directory does not even exist. It only exists up until /Users/yusufkelo/Library/Application Support/ , After /Application Support/ the remaining directories never existed
    – Neo
    Aug 8, 2023 at 23:29
  • Quick update, there is a tracking issue. I can reproduce the error and as workaround you can run the network with the flag -c 1 (to use single concurrency for spawning the nodes)
    – pepoviola
    Aug 12, 2023 at 1:05

1 Answer 1

2

quick workaround for this issue (as described here https://github.com/paritytech/zombienet/issues/1237#issuecomment-1675507189), is to run zombienet with concurrency set to 1.

zombienet-macos -p native -c 1-d zn-db spawn ./zombienet-config.toml

This should work as expected, until we review the locking issue. Thanks!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.