0

I am doing a basic E2E test using the flipper example.

This is my contract version

enter image description here

I have install the substrate-contracts-node

I am running with the "nightly-2023-02-09" (cargo +nightly-2023-02-09 test --features e2e-tests)

Does anyone knows why this happens ?

---- flipper::e2e_tests::it_works stdout ----
thread 'flipper::e2e_tests::it_works' panicked at 'We should find a port before the reader ends', /home/silveira/.cargo/registry/src/github.com-1ecc6299db9ec823/ink_e2e-4.2.1/src/node_proc.rs:192:10
note: run with `RUST_BACKTRACE=1` environment variable to display a backtrace

enter image description here

Cargo.toml

[package]
name = "flipper"
version = "0.1.0"
authors = ["Parity Technologies <[email protected]>"]
edition = "2021"
publish = false

[dependencies]
ink = { version = "4.2.1", default-features = false }

scale = { package = "parity-scale-codec", version = "3.6.3", default-features = false, features = ["derive"] }
scale-info = { version = "2.5", default-features = false, features = ["derive"], optional = true }

[dev-dependencies]
ink_e2e = { version = "4.2.1" }

[lib]
path = "src/lib.rs"

[features]
default = ["std"]
std = [
    "ink/std",
    "scale/std",
    "scale-info/std",
]
ink-as-dependency = []
e2e-tests = []

2
  • Note : this is a question. i have this configuration Rust > = 1.70 + pallet-contracts >= polkadot-1.0.0 = cargo-contract 4.0.0-alpha but i still have the same error
    – Honour
    Aug 11, 2023 at 12:41
  • Hi, the e2e test does not work after the 3.1.0 has been yanked for either versions of it. Cheers.
    – Evil Kyle
    Aug 11, 2023 at 13:41

1 Answer 1

1

Looks like cargo-contract 3.1.0 has been yanked.

cargo-contract compatibility with different rust toolchains:

  • Rust <= 1.69 + pallet-contracts < polkadot-1.0.0 = cargo-contract 3.0.1
  • Rust > = 1.70 + pallet-contracts >= polkadot-1.0.0 = cargo-contract 4.0.0-alpha

The e2e test does not work after the 3.1.0 has been yanked for either versions of it.

A new version cargo-contract 3.2.0 was release but the error remains(Issue).


Update Update Update Update Update Update Update Update

This was sorted with the ink version 4.3.

cargo.toml

[package]
name = "flipper"
version = "0.1.0"
authors = ["Parity Technologies <[email protected]>"]
edition = "2021"
publish = false

[dependencies]
ink = { version = "4.3.0", default-features = false }
scale = { package = "parity-scale-codec", version = "3", default-features = false, features = ["derive"] }
scale-info = { version = "2.5", default-features = false, features = ["derive"], optional = true }

[dev-dependencies]
ink_e2e = { version = "4.3.0" }

[lib]
path = "src/lib.rs"

[features]
default = ["std"]
std = ["ink/std", "scale/std", "scale-info/std"]
ink-as-dependency = []
e2e-tests = []

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.