2

I have been integrating EVM(43 version) in 43 version of substrate. while adding files to runtime module i am getting sys error while building it .I want to know how to solve this errorenter image description here

2
  • What do you mean 43 version? Jul 25, 2023 at 5:27
  • here i am referring it the branch (polkadot-v0.9.43) and same for Evm frontier branch (polkadot-v0.9.43) Jul 25, 2023 at 5:47

1 Answer 1

1

There is something wrong with your imports, check your Cargo.toml.

As an example if you check this previous StackExchange issue: file not found for module sys.

It worked using the default-features = false in pallet_session instead of features = ["historical"]

2
  • 1
    it was similar to that i have missed writing default-features false in one the pallets Aug 24, 2023 at 5:39
  • I also got the same error. But cannot understand what you explained here. could you please explain a bit more about how to solve this issue? Oct 10, 2023 at 9:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.