1

I am following a tutorial. What I am trying to connect two different nodes to each other who are Alice and Bob. Alice node works properly, but Bob node gets this following error:

2023-07-09 18:20:01 🏷  Local node identity is: 12D3KooWQom91ucC8REm1PNnyB1RLNjGuFXSRq52saUCKsZuZPzU
2023-07-09 18:20:01 Can't listen on /ip6/::/tcp/30333/ws because: Other(Custom { kind: Other, error: Other(A(A(A(A(A(Transport(Transport(Os { code: 98, kind: AddrInUse, message: "Address already in use" })))))))) })
2023-07-09 18:20:01 Can't listen on /ip4/0.0.0.0/tcp/30333/ws because: Other(Custom { kind: Other, error: Other(A(A(A(A(A(Transport(Transport(Os { code: 98, kind: AddrInUse, message: "Address already in use" })))))))) })
2023-07-09 18:20:01 πŸ’» Operating system: linux
2023-07-09 18:20:01 πŸ’» CPU architecture: x86_64
2023-07-09 18:20:01 πŸ’» Target environment: gnu
2023-07-09 18:20:01 πŸ’» CPU: AMD Ryzen 3 3200U with Radeon Vega Mobile Gfx
2023-07-09 18:20:01 πŸ’» CPU cores: 2
2023-07-09 18:20:01 πŸ’» Memory: 2850MB
2023-07-09 18:20:01 πŸ’» Kernel: 5.15.90.1-microsoft-standard-WSL2
2023-07-09 18:20:01 πŸ’» Linux distribution: Ubuntu 22.04.2 LTS
2023-07-09 18:20:01 πŸ’» Virtual machine: yes
2023-07-09 18:20:01 πŸ“¦ Highest known block at #0
2023-07-09 18:20:01 Running JSON-RPC HTTP server: addr=127.0.0.1:43677, allowed origins=["http://localhost:*", "http://127.0.0.1:*", "https://localhost:*", "https://127.0.0.1:*", "https://polkadot.js.org"]
2023-07-09 18:20:01 Running JSON-RPC WS server: addr=127.0.0.1:36565, allowed origins=["http://localhost:*", "http://127.0.0.1:*", "https://localhost:*", "https://127.0.0.1:*", "https://polkadot.js.org"]
2023-07-09 18:20:01 discovered: 12D3KooWFqJMcHVLLmZrhzVSorDEUZGX8HPW1Jhx1zjvZ86N5ydP /ip4/172.20.154.189/tcp/30333/ws

The interesting thing is that even though it discovered Alice node, does not connect to it because Idle (0 peers) writes in the the terminal. I would appreciate if the solution is found. Thanks in advance.

1
  • Which tutorial did you use?
    – Simson
    Dec 7, 2023 at 7:09

1 Answer 1

1

"Address already in use."

  • Most likely you already have another node running.
  • Basically this means something is occupying that port.

Check all your terminals, VS Code terminals, processes and kill the additional node.

If all else, fails, restart your machine and try booting up Alice and Bob again.

2
  • I did what you said. As soon as the pc starts, I started the nodes, but the problem still continue Jul 9, 2023 at 15:49
  • 1
    I do not know how but i fixed it :) Jul 9, 2023 at 16:42

Your Answer

By clicking β€œPost Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.