The command substrate build-spec > plain-chain-spec.json used to generate a human readable version of the chain spec in json. To create the more stable machine friendly version of that chain spec one must call: substrate build-spec --raw > raw-chain-spec.json. But now that I'm testing a node built on top of Polkadot 0.9.42, I'm observing that the output of the former command is also raw! How can the plain version is producible then?

  • When I specified the chain in the build-spec command, this time around the result was indeed plain!
    – Alex Sed
    Jun 26 at 1:25

1 Answer 1


There might be some issue with the command you are using to generate the plain spec file, you can follow the steps mentioned in this tutorial https://docs.substrate.io/tutorials/build-a-blockchain/add-trusted-nodes/#create-a-custom-chain-specification, also the command to generate the plain spec file is as follows:

./target/release/node-template build-spec --disable-default-bootnode --chain local > customSpec.json

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.