5

I've launched several substrate nodes in several clouds, one of which is Digital Ocean. The telemetry at telemetry.polkadot.io works just fine, it shows all the nodes and block generated in the real-time.

The problem is that https://polkadot.js.org/apps/#/explorer doesn't connect to any of my blockchain nodes, with the error message "The operation is insecure."

This is how I launch my cloud node:

./target/release/node-template \
--chain=customSpecRaw.json \
--alice \
--validator \
--rpc-cors=all \
--rpc-methods=Unsafe \
--unsafe-rpc-external \
--unsafe-ws-external \
--no-mdns \
--telemetry-url 'wss://telemetry.polkadot.io/submit/ 0' \
--prometheus-external \
--name='Digital Ocean Cloud Node'

Allowing all inbound and outbound traffic on ports for tcp, http, https (ports: 22, 80, 443) on my cloud VM didn't solve the problem.

I'd be grateful if you tell me if I'm doing something wrong.

1 Answer 1

7

It's probably going to give that error if you're trying to connect to it through ws (i.e. http) rather than wss (https). If you haven't already, try deploying an SSL certificate to your server (you can get a time-limited one for free from zerossl). Deploy the SSL certificate on an nginx instance, receive the traffic on the SSL-enabled TCP port and reverse-proxy the traffic to your node.

There's also a guide in the Polkadot wiki here.

2
  • It works! Thank you! Mar 21, 2022 at 11:24
  • great! you're welcome!
    – kukabi
    Mar 21, 2022 at 17:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.