3

Recently anytime i try to run substrate-node i get this error message, all attempts to update packages hasn't been helpful

Error: Service(Client(VersionInvalid("cannot deserialize module: UnknownOpcode(192)")))
2023-06-22 02:56:29.665  WARN main wasm-runtime: Cannot create a runtime error=Other("cannot deserialize module: UnknownOpcode(192)")

2 Answers 2

0

This is a substrate issue with latest rust (after 1.69) and releases before polkadot-v0.9.39. You should use nightly-2023-01-01 or rustc at 1.68 or earlier to compile:

cargo +nightly-2023-01-01 build --release

More info here : cannot run substrate on a fresh macbook m2

2
  • I have tried the option of using an earlier nightly version but the issue still persists Commented Jun 22, 2023 at 16:03
  • Please anyone who can help me on this, I have been stuck for days and tried every suggestion i could fine but none is working ``` error: failed to run custom build command for wasm-opt-sys v0.111.0 Caused by: process didn't exit successfully:``` Commented Jun 25, 2023 at 4:25
0

Finally figured it out after trying all the options, running this helps rebuild the dependencies for rocksdb pacman -U https://archive.archlinux.org/packages/g/gcc/gcc-12.2.1-4-x86_64.pkg.tar.zst https://archive.archlinux.org/packages/g/gcc-libs/gcc-libs-12.2.1-4-x86_64.pkg.tar.zst

1
  • Hmmm. I don’t think so. I’ve a lot of arch linux machines. No one can reproduce this. (I always keeping everything up to date)
    – AurevoirXavier
    Commented Jun 25, 2023 at 22:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.