When I try to deploy a solidity smart contract on my substrate node I get the following error:

"Gas estimation failed Gas estimation errored with the following message (see below). The transaction execution will likely fail. Do you want to force sending? Returned error: {"jsonrpc":"2.0","error":"unknown field type, expected one of from, to, gasPrice, maxFeePerGas, maxPriorityFeePerGas, gas, value, data, nonce, accessList at line 1 column 8639","id":339420499546212}". How to solve this problem?

enter image description here

  • If I send the transaction anyway, I get the following error: creation of CodeWithJoe errored: Returned error: {"jsonrpc":"2.0","error":"[ethjs-query] while formatting outputs from RPC '{\"value\":{\"code\":-32603,\"data\":{\"code\":-32603,\"message\":\"submit transaction to pool failed: Pool(InvalidTransaction(InvalidTransaction::Custom(3)))\"}}}'","id":4447184481249369} May 16, 2023 at 13:11
  • have you tried decreasing the gas_fee ? May 17, 2023 at 5:05
  • @AmitKumarYadav Yes but I get the same error May 18, 2023 at 14:04
  • is this error comes when you try to transfer tokens? May 19, 2023 at 5:13
  • No, it's an error when I try to deploy an evm contract on my substrate node. May 22, 2023 at 14:25

1 Answer 1


This error generally occur due to the wrong gas_estimation to get rid of this error you can decrease the gas_feeof your chain or you can use metamask advance options to set the gas_limit manually.you can also decrease the gas_limit given in remix ide 3000000 to 30000. you can see this to customize the gas_limit on metamask or you can simply decrease your gas_fee.

  • 1
    Thanks @Amit after decreasing the gas_fee it solves my problem. May 16, 2023 at 11:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.