2

I tried to clone https://github.com/polkadot-js/apps and run on local. When I execute yarn or yarn install, I get below logs:

➤ YN0013: │ @polkadot/react-identicon@npm:3.4.1 can't be found in the cache and will be fetched from the remote registry
➤ YN0013: │ @polkadot/react-qr@npm:3.4.1 can't be found in the cache and will be fetched from the remote registry
➤ YN0013: │ @polkadot/networks@npm:12.2.1 can't be found in the cache and will be fetched from the remote registry
➤ YN0013: │ @polkadot/phishing@npm:0.21.3 can't be found in the cache and will be fetched from the remote registry
➤ YN0013: │ @polkadot/react-identicon@npm:3.4.1 can't be found in the cache and will be fetched from the remote registry
➤ YN0013: │ @polkadot/react-qr@npm:3.4.1 can't be found in the cache and will be fetched from the remote registry
➤ YN0013: │ @polkadot/rpc-augment@npm:10.7.1 can't be found in the cache and will be fetched from the remote registry

My node version is v19.4.0 and yarn version is 3.2.0. Can somebody please help me fix this?

Thanks in advance.

1 Answer 1

6

The logs you posted above are not error logs, but this is yarn berry informing you that you don't have those packages cached (probably because this is your first install), and will fetch them from the registry.

After you yarn install you need to run yarn start or yarn start:electron in order to run polkadot-js/apps locally.

2
  • It is still not working. When I execute yarn run start, it says Error: listen EADDRINUSE: address already in use :::3000 at Server.setupListenHandle [as _listen2] (node:net:1741: There is no process on my system running on 3000. I also restarted my system. Is there any way to change port? Or I am missing anything?
    – Boleng
    May 15, 2023 at 8:58
  • 1
    Just to ensure when you run lsof -i :3000 you get no output? And yes there is most certainly a way to change the port. Inside of packages/apps/webpack.serve.cjs you can change the devServer port.
    – Tarik Gul
    May 15, 2023 at 12:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.