2

I'm trying to clone and build this branch (supersig-v1.0.0-ninja-2), but getting an issue on my mac, while on ubuntu it works fine.

yarn build:

error:

apps % yarn build:code
$ polkadot-dev-build-ts 
$ yarn polkadot-dev-clean-build
$ polkadot-dev-clean-build 
$ yarn build:extra

   3 not referenced in chains ::

         chainsDustyPNG, chainsMangataxPNG, chainsPicassoSVG 


  18 not referenced in nodes ::

         nodesAresPNG, nodesBeastSVG, nodesEaveSVG, nodesIdavollPNG, nodesIpseSVG, nodesKonomiPNG, nodesMoonrockPNG, nodesParamiJPEG, nodesPlasmPNG, nodesShellSVG, nodesSinglavenderSVG, nodesSubstrateCircleSVG, nodesSubstrateHexagonSVG, nodesSubstrateWhiteSVG, nodesUnitvPNG, nodesValiuPNG, nodesVaraSVG, nodesZenlinkSVG 

$ polkadot-dev-run-test --env node --require ./scripts/fixupModules.cjs --experimental-specifier-resolution=node packages/apps-config/src/api/typesBundle.spec.ts
$ /usr/local/bin/node --no-warnings --enable-source-maps --loader @polkadot/dev/node/ts --require @polkadot/dev/node/test/node --require ./scripts/fixupModules.cjs --experimental-specifier-resolution=node /Users/ramsey/new-apps/apps/node_modules/@polkadot/dev/scripts/polkadot-exec-node-test.mjs packages/apps-config/src/api/typesBundle.spec.ts
SyntaxError: The requested module 'node:test' does not provide an export named 'run'
    at ModuleJob._instantiate (node:internal/modules/esm/module_job:123:21)
    at async ModuleJob.run (node:internal/modules/esm/module_job:189:5)
    at async Promise.all (index 0)
    at async ESMLoader.import (node:internal/modules/esm/loader:533:24)
    at async loadESM (node:internal/process/esm_loader:91:5)
    at async handleMainPromise (node:internal/modules/run_main:65:12)
Error: Command failed: yarn build:extra
    at checkExecSyncError (node:child_process:841:11)
    at Object.execSync (node:child_process:912:15)
    at execSync (file:///Users/ramsey/new-apps/apps/node_modules/@polkadot/dev/scripts/util.mjs:79:6)
    at main (file:///Users/ramsey/new-apps/apps/node_modules/@polkadot/dev/scripts/polkadot-dev-build-ts.mjs:946:5)
    at file:///Users/ramsey/new-apps/apps/node_modules/@polkadot/dev/scripts/polkadot-dev-build-ts.mjs:988:1
    at ModuleJob.run (node:internal/modules/esm/module_job:193:25)
    at async Promise.all (index 0)
    at async ESMLoader.import (node:internal/modules/esm/loader:533:24)
    at async loadESM (node:internal/process/esm_loader:91:5) {
  status: 1,
  signal: null,
  output: [ null, null, null ],
  pid: 29518,
  stdout: null,
  stderr: null
}

highlighted error:

SyntaxError: The requested module 'node:test' does not provide an export named 'run'

1 Answer 1

5

So i was able to get your code built. I would ensure you are using the correct version of node as the error you are posting comes from node-js itself.

Ensure you are using version 18.15 or higher as declared in the engine field in the package.json.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.