I recently ran into issues with working on my substrate-node-template.

i had this issue as mentioned here:

and as far I found out, the error I am running into are related to: https://github.com/paritytech/subport/issues/32#issuecomment-1493893071 and should be fixed by: https://github.com/paritytech/substrate/pull/13804

so, these errors are addressed, but I think something is still not right.

I explain my error here:

and I was able to get the vanilla substrate-node-template working after downgrading with:

rustup install 1.68.0
rustup default 1.68.0

rustup toolchain install nightly-2023-01-30
rustup target add wasm32-unknown-unknown --toolchain nightly-2023-01-30
rustup override set nightly-2023-01-30

So far, I get the vanilla substrate-node-template running by following the tutorial. But when I try to clone the repository while changing the root folder name from substrate-node-template to example-chain-devnet the node is not starting and is still get the error code:

2023-04-09 16:20:53 Substrate Node
2023-04-09 16:20:53 ✌️  version 4.0.0-dev-d9063560dce
2023-04-09 16:20:53 ❤️  by Substrate DevHub <https://github.com/substrate-developer-hub>, 2017-2023
2023-04-09 16:20:53 📋 Chain specification: Development
2023-04-09 16:20:53 🏷  Node name: lacking-hose-6088
2023-04-09 16:20:53 👤 Role: AUTHORITY
2023-04-09 16:20:53 💾 Database: RocksDb at /tmp/substrate4iUG4H/chains/dev/db/full
2023-04-09 16:20:53 ⛓  Native runtime: node-template-100 (node-template-1.tx1.au1)
Error: Service(Client(VersionInvalid("cannot deserialize module: UnknownOpcode(192)")))
2023-04-09 16:20:53 Cannot create a runtime error=Other("cannot deserialize module: UnknownOpcode(192)")

I know that the node can normally run with another called root folder then "substrate-node-template" because i was already working on substrate-node-templates which I modified.

At current point, I am unable to start any of my previous work (modified substrate-node-templates). (Build is failing with UnknownOpcode(192))

I can only git clone the substrate node template and then apply my changes to the chainspec.rs without being able to rename the root folder.

Does anybody experience the same or know what i am doing wrong?

  • This is a better question for the answer in the linked question.
    – Simson
    Commented Apr 10, 2023 at 1:08

1 Answer 1


UnknownOpcode(192) seems to be compiler related with rust versions around 1.68.

As you already know rollback tool-chain to nightly-2023-01-01 solves the problem.

Then build with cargo +nightly-2023-01-30 build (was this the part missing?)

For instance you can add this in your cargo.toml

channel = "nightly-2023-01-01"
components = [ "rustfmt" ]
targets = [ "wasm32-unknown-unknown" ]
profile = "minimal"
  • solve the issue on substrate-node-template repo by running rustup override set nightly-2023-01-01 && rustup target add wasm32-unknown-unknown.
    – amazing
    Commented May 5, 2023 at 12:14

Not the answer you're looking for? Browse other questions tagged or ask your own question.