2

I followed the tutorial on https://docs.substrate.io/tutorials/build-a-blockchain/build-local-blockchain/ exactly, but after building the node template (https://github.com/substrate-developer-hub/substrate-node-template) and trying to run it with ./target/release/node-template --dev I get the following error message:

Error: Service(Client(VersionInvalid("cannot deserialize module: UnknownOpcode(192)")))
2023-04-04 21:13:57 Substrate Node    
2023-04-04 21:13:57 ✌️  version 4.0.0-dev-700c3a186e5    
2023-04-04 21:13:57 ❤️  by Substrate DevHub <https://github.com/substrate-developer-hub>, 2017-2023    
2023-04-04 21:13:57 📋 Chain specification: Development    
2023-04-04 21:13:57 🏷  Node name: future-carriage-5924    
2023-04-04 21:13:57 👤 Role: AUTHORITY    
2023-04-04 21:13:57 💾 Database: RocksDb at /tmp/substrate7hcjlL/chains/dev/db/full    
2023-04-04 21:13:57 ⛓  Native runtime: node-template-100 (node-template-1.tx1.au1)    
2023-04-04 21:13:57 Cannot create a runtime error=Other("cannot deserialize module: UnknownOpcode(192)")

1 Answer 1

3

This issue happens in recent rust nightly builds, try downgrading to nightly-2023-03-14

More info:

Once you downgrade the nightly toolchain, you will have to build the project again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.