2

I'm using zombienet v1.3.30. My config file is like this:

[[parachains]]
id = 100
cumulus = true

  [parachains.collator]
  name = "collator01"
  chain_spec_path = "./bin/chain/specs/collatorSpecRaw.json"
  command = "./bin/chain/{{ZOMB_OS}}/parachain"
  ws_port = "{{ZOMB_WS_PORT}}"

I see that the parachain id is set with id = 100 in the parachains heading, but my parachain node binary doesn't support the flag --parachain-id so it fails to launch the collator.

error: Found argument '--parachain-id' which wasn't expected, or isn't valid in this context

The para id is already in the chain spec, so I was wondering if there's a way to remove the flag rather than override it? Otherwise I guess I'll have to try older zombienet versions or rebuild the current one without it.

1 Answer 1

1

the flag for the parachain is cumulus_based. Should work with this config.

Thanks!!

[[parachains]]
id = 100
cumulus_based = true

  [parachains.collator]
  name = "collator01"
  chain_spec_path = "./bin/chain/specs/collatorSpecRaw.json"
  command = "./bin/chain/{{ZOMB_OS}}/parachain"
  ws_port = "{{ZOMB_WS_PORT}}"
2
  • ah shoot. How obvious, ty.
    – Camtensor
    Feb 2, 2023 at 21:17
  • Thanks! You really help!
    – rust.dev
    Feb 6, 2023 at 20:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.