2

I'm trying to build a custom pallet using the substrate-node-template, and when I run cargo check on the pallet, it's all good. But when I run cargo check or cargo build --release on the whole node, I get this error:

error[E0369]: cannot multiply `&&EdwardsBasepointTable` by `&Scalar`
   --> /home/penay/.cargo/registry/src/github.com-1ecc6299db9ec823/snow-0.9.0/src/resolvers/default.rs:132:47
    |
132 |         let point = (&ED25519_BASEPOINT_TABLE * &self.privkey).to_montgomery();
    |                      ------------------------ ^ ------------- &Scalar
    |                      |
    |                      &&EdwardsBasepointTable
    |
help: `*` can be used on `&EdwardsBasepointTable` if you dereference the left-hand side
    |
132 |         let point = (*&ED25519_BASEPOINT_TABLE * &self.privkey).to_montgomery();
    |                      +

For more information about this error, try `rustc --explain E0369`.
error: could not compile `snow` due to previous error

I have no clue what it may be, since it's not something I built or interacted with, at least not that I know of.

3

2 Answers 2

1

I got this too.

Because I did the cargo update recently.

cargo update -p [email protected] --precise 4.0.0-pre.5

Downgrading a specific package works for me.

1
  • This worked for me. Thanks!
    – Maario
    Apr 4, 2023 at 12:49
0

There is an issue for it https://github.com/mcginty/snow/issues/146 And few solutions PRs open https://github.com/mcginty/snow/pull/147 https://github.com/mcginty/snow/pull/148

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.