2

Is there a way to suppress this warning when using Polkadot.js?

API/INIT: RPC methods not decorated: chainHead_unstable_body, chainHead_unstable_call, chainHead_unstable_follow, chainHead_unstable_genesisHash, chainHead_unstable_header, chainHead_unstable_stopBody, chainHead_unstable_stopCall, chainHead_unstable_stopStorage, chainHead_unstable_storage, chainHead_unstable_unfollow, chainHead_unstable_unpin, mmr_root, mmr_verifyProof, mmr_verifyProofStateless, transaction_unstable_submitAndWatch, transaction_unstable_unwatch
1
  • I'm using "@polkadot/api": "^9.13.6", and I added new ApiPromise({ provider, rpc: customRpc, noInitWarn: true }); but it still display warning Commented May 9, 2023 at 3:17

1 Answer 1

5

Yes this is possible. When instatiating your ApiPromise, you may pass in noInitWarn: true as an option.

Here is the actual field in the interface ApiOptions type.

1
  • 1
    this works. thanks! Commented Jan 19, 2023 at 21:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.