0

I have a situation where I uploaded the genesis wasm and state to the relay chain network, and then proceeded to make a few changes to the parachain node after that and compile it. When I ran the new parachain node I was greeted with :

Could not find the header of the genesis block in the database! block_hash=0xb2..1e

Instead of trying to purge and restart my relay chain network (which already has paraID 2000 registered), I am trying to salvage the situation for educational reasons.

For this I did the following:

  1. Regenerate raw chain spec for the parachain, purge the old parachain database, run the parachain with new chain spec.
  2. export the genesis-wasm and genesis-state for this parachain and upload it to the relay chain with a sudo call to paras.forceSetCurrentCode(2000, newCode) and paras.forceSetCurrentHead(2000, newHead).
  3. Restart parachain node.

The error still persists and my parachain refuses to build new blocks.

4
  • Did you offboard your parachain first? sudo sub-page, pick parasSudoWrapper > sudoScheduleParaCleanup Jan 10, 2023 at 10:04
  • @DaanvanderPlas I did not (didn't know about this). Will try out this solution thanks. Jan 10, 2023 at 10:39
  • did it resolve the issue? Jan 13, 2023 at 9:38
  • @DaanvanderPlas I had forgotten about this. I tried to reproduce this error, but this time I wasn't able to produce that error, I think I am missing something, so I cannot verify that sudoScheduleParaCleanup would've been the correct solution. Jan 13, 2023 at 12:19

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.