2

ink! v4.0.0 release is incoming. As mentioned in v4.0.0 pre-release page, substrate pallet-contracts later than this commit (shows up in polkadot-v0.9.32 branch for the first time) start to support ink! v4.0.0.

Are there any backward incompatibility issues with ink! v3.4.0 or lower? which contracts developers need to be aware of. If yes, what exactly are they?

1 Answer 1

2

Are there any backward incompatibility issues with ink! v3.4.0 or lower?

The pallet-contracts will continue supporting already deployed contracts and you will still be able to deploy ink! contracts lower than 4.0.

Since smart contracts are immutable execution environment (like pallet-contracts or EVM) will continue supporting already deployed ones.

If you are asking in terms of compatibility of your ink! v3.x code with 4.0: there are a couple of changes we made to the API. It's easy to migrate your contract code from 3.x to 4.0 though and we've written this migration guide for it: https://use.ink/faq/migrating-from-ink-3-to-4/.

1
  • 1
    I see, thank you so much for the detailed explanation!
    – Shunsuke
    Mar 14, 2023 at 6:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.