1

Good day, everyone!

I'm running an Astar validator node.
When I upgraded the version from v4.23.0 to v4.33.0, an error occurred.

2022-11-24 02:06:57 Astar Collator
2022-11-24 02:06:57 :vサイン:  version 4.33.0-9b953e5dafb
2022-11-24 02:06:57 :ハート:  by Stake Technologies <[email protected]>, 2019-2022
2022-11-24 02:06:57 :クリップボード: Chain specification: Astar
2022-11-24 02:06:57 :ラベルタグ:  Node name: astar
2022-11-24 02:06:57 :上半身シルエット_1: Role: AUTHORITY
2022-11-24 02:06:57 :フロッピーディスク: Database: RocksDb at /data/chains/astar/db/full
2022-11-24 02:06:57 :鎖:  Native runtime: astar-43 (astar-0.tx2.au1)
2022-11-24 02:06:58 Parachain id: Id(2006)
2022-11-24 02:06:58 Parachain Account: 5Ec4AhPW97z4ZyYkd3mYkJrSeZWcwVv4wiANES2QrJi1x17F
2022-11-24 02:06:58 Parachain genesis state: 0x000000000000000000000000000000000000000000000000000000000000000000de2e3567ab0b52f4d9bca7efadf6e7b
fe0f453c356d0a7962e4227cfaefe5ab403170a2e7597b7b7e3d84c05391d139a62b157e78786d8c082f29dcf4c11131400
2022-11-24 02:06:58 Is collating: yes
2022-11-24 02:06:58 [Parachain] :ハンマー: Running Frontier DB migration from version 1 to version 2. Please wait.
====================
Version: 4.33.0-9b953e5dafb
   0: sp_panic_handler::set::{{closure}}
   1: std::panicking::rust_panic_with_hook
             at rustc/93ffde6f04d3d24327a4e17a2a2bf4f63c246235/library/std/src/panicking.rs:702:17
   2: std::panicking::begin_panic_handler::{{closure}}
             at rustc/93ffde6f04d3d24327a4e17a2a2bf4f63c246235/library/std/src/panicking.rs:588:13
   3: std::sys_common::backtrace::__rust_end_short_backtrace
             at rustc/93ffde6f04d3d24327a4e17a2a2bf4f63c246235/library/std/src/sys_common/backtrace.rs:138:18
   4: rust_begin_unwind
             at rustc/93ffde6f04d3d24327a4e17a2a2bf4f63c246235/library/std/src/panicking.rs:584:5
   5: core::panicking::panic_fmt
             at rustc/93ffde6f04d3d24327a4e17a2a2bf4f63c246235/library/core/src/panicking.rs:142:14
   6: astar_collator::rpc::open_frontier_backend
   7: astar_collator::parachain::service::start_node_impl::{{closure}}
   8: <core::future::from_generator::GenFuture<T> as core::future::future::Future>::poll
   9: sc_cli::走る人::Runner<C>::run_node_until_exit
  10: astar_collator::command::run
  11: astar_collator::main
  12: std::sys_common::backtrace::__rust_begin_short_backtrace
  13: std::rt::lang_start::{{closure}}
  14: main
  15: __libc_start_main
  16: _start

Parameters are set as follows.

- args:
        - '--collator'
        - '--name'
        - astar
        - '--chain'
        - astar
        - '--base-path'
        - /data
        - '--rpc-cors'
        - all
        - '--unsafe-rpc-external'
        - '--execution'
        - wasm
        - '--trie-cache-size'
        - '1'
        - '--telemetry-url'
        - 'wss://telemetry.polkadot.io/submit/ 0'

Any advice would be appreciated.
Best regerd!!

1 Answer 1

3

Please check release note v4.29.1 https://github.com/AstarNetwork/Astar/releases/tag/v4.29.1 In case frontier DB migration failure, please delete frontier db.

{base-path}/chains/shiden/frontier or {base-path}/chains/astar/frontier

1
  • Thank you very much. It was successfully resolved!
    – Satish
    Nov 25, 2022 at 2:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.