0

I have an error while cargo build -- release on polkadot v0.9.31

error: failed to select a version for `parity-util-mem`.
    ... required by package `sp-core v6.0.0`
    ... which satisfies dependency `sp-core = "^6.0.0"` of package `sp-keyring v6.0.0`
    ... which satisfies dependency `sp-keyring = "^6.0.0"` of package `integration-tests v4.0.0-dev (/eric/VoiceBanBackend/integration-tests)`
versions that meet the requirements `^0.11.0` are: 0.11.0

the package `parity-util-mem` links to the native library `parity-util-mem-ban-duplicates`, but it conflicts with a previous package which links to `parity-util-mem-ban-duplicates` as well:
package `parity-util-mem v0.12.0`
    ... which satisfies dependency `parity-util-mem = "^0.12.0"` of package `sc-informant v0.10.0-dev (https://github.com/paritytech/substrate.git?branch=polkadot-v0.9.31#7a4e5163)`
    ... which satisfies git dependency `sc-informant` of package `sc-service v0.10.0-dev (https://github.com/paritytech/substrate.git?branch=polkadot-v0.9.31#7a4e5163)`
    ... which satisfies git dependency `sc-service` of package `node-template v4.0.0-dev (/eric/VoiceBanBackend/node)`
Only one package in the dependency graph may specify the same links value. This helps ensure that only one copy of a native library is linked in the final binary. Try to adjust your dependencies so that only one package uses the links ='parity-util-mem' value. For more information, see https://doc.rust-lang.org/cargo/reference/resolver.html#links.

I saw niklasad1's commit, it is still under review. I'd like to use the latest polkadot version that include sp-core v7.0.0

1 Answer 1

0

Errors like this happen when you mess up the Cargo.lock file. (which you shouldn't do)

You should reset your branch, removing any changes from origin, and try compiling again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.