1

I run the tutorials to prepare a local relay chain form Substrate:

https://docs.substrate.io/tutorials/connect-relay-and-parachains/prepare-a-local-relay-chain/

And it worked as expected. However if run the nodes again I am getting this issue:

Error with block built on 0x9001e151c98fa89bfef8faa81e517f0b28b32fb6e327721f0a8ca99519b8e0e9: Import failed: Unexpected epoch change 

And when I try to send a transaction, it got stuck and doesn't work.

1 Answer 1

0

This is an error from BABE. Relate to the consensus algorithm.

You didn't produce any blocks during the whole session. So the chain stops working.

There is no easy way to recover this. And you are in the test env. The best choice is clean the old data and restart the chain.

2
  • 1
    Cleaning all and restarting worked! Thanks Oct 25, 2022 at 10:24
  • This seems like a fundamental design flaw and a show stopper for a blockchain application. A key design consideration of a blockchain is resiliency, and bricking simply by doing nothing and allow time to lapse seems crazy. The workaround is just to restart the chain from genesis (?)
    – Max
    Nov 6, 2022 at 16:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.