1

I recently update Swanky Suite latest version @astar-network/swanky-cli/0.2.1 darwin-x64 node-v16.14.0. I create new project with swanky init my_project but throws Error Installing dependencies. Is there any issue in latest release? or I am doing something wrong? I also compile the project and error Error: command compile not found. enter image description here

2 Answers 2

2

I had the same issue. Upgrade your NodeJS version to v18.10.0.

You can also look at the pull request

1
  • 1
    thanks for answer, after upgrade nodejs version problem solved
    – Ganesh11
    Oct 22, 2022 at 3:10
2

Only dependency is swanky itself. Can you check the package.json in the newly created project, and what happens if you run yarn (npm i) manually?

The compile command has been updated. It is now under contract command. So the correct way to call it is: swanky contract compile flipper

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.