I am using Swanky Suite, contract compile successfully but while deploy using swanky deploy --account alice --contract flipper --gas 100000000 --args true throws ENOENT: no such file or directory, open error. Swanky node also run in next tab. Why contract doesn't deploy?

enter image description here

  • 2
    looking at the screenshot, you are indeed missing the wasm binary and metadata.json. If the compile step was completed correctly, those should have been there. Can you run the compile command again with --verbose flag and check the output?
    – codespool
    Commented Oct 21, 2022 at 7:57
  • 1
    and please add ls printout for flipper/target/ink folder
    – Maario
    Commented Oct 21, 2022 at 7:59
  • 1
    thanks for comments, I have issue with nodejs version now works fine
    – go11li
    Commented Oct 22, 2022 at 3:09
  • I had the same error, but noted that the previous compile step fails even though it gives green checkmarks: ⠋ Copying artifacts[Error: ENOENT: no such file or directory, copyfile '/home/justin/dev/chocolate-wasm/artifacts/asset.contract' -> '/home/justin/dev/chocolate-wasm/artifacts/asset/1673627007627/asset.wasm'. What version of nodejs worked for you? Commented Jan 13, 2023 at 16:29
  • I am using @astar-network/swanky-cli/1.0.7-jp-workshop.3 darwin-x64 node-v18.12.1
    – go11li
    Commented Jan 14, 2023 at 1:41

1 Answer 1


I'm re-posting the answer from the comment here to remove the question from the unanswered section:

The issue was an old version of node.js.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.