I am running a local testnet of a 2-validator-node polkadot Relay Chain (release-v0.9.27) and I am trying to connect a parachain-template to it (v0.9.27), with custom keys. The Relay Chain is working as intended, producing and finalizing blocks.

When I connect the parachain (have tried with 1 collator and 2 collators) to the Relay Chain, the parachain tries to import the first block but never does it, and all I get is Collation wasn't advertised to any validator. That procedure continues for a while (5-10mins) and then I get the following errors:

[Parachain] Block import error: State Database error: Too many sibling blocks inserted
[Parachain] Error with block built on 0xda79ce961787fcc5e5a97a19cd2a03695b30ee1791fb94a5045cf58f164951d0: Import failed: State Database error: Too many sibling blocks inserted
[Parachain] Failed to collect collation info. error=Application(UnknownBlock("Header was not found in the database: 0x89acf273da66c70e14bd8c5daac0f82235522d15a61ef0a06d925dcf08a3340d"))

I have checked everything in these sanity checklists (How can I get my parachain to produce blocks? (sanity checklist) and Our parachain doesn't produce blocks [checklist]) and everything should work.

I have also tried increasing the Validator count of the Relay Chain to 3 and I am still getting the same results.

  • Can you please give more information on how you run the nodes? Do you use docker? Or anything else? You could try running with --discover-local.
    – bkchr
    Oct 19, 2022 at 13:23
  • 1
    I am using github.com/CherryNetwork/polkadot (branch = cherry) and github.com/CherryNetwork/evm-parachain/tree/main/runtime (branch = main). I am not using a docker. I just build and run. The steps I am doing in more details are the following: 1. Spin up the first validator Relay node 2. Spin up the second validator Relay node 3. Insert their keys through a curl command 4. Register the ParaId (2000) 5. Spin the parachain collator node 6. Insert their keys through a curl command 7. Use parasSudoWrapper to Initialize the parachain
    – Zycon
    Oct 19, 2022 at 13:54
  • 2
    I have also tried running the v0.9.27 and v0.9.28 polkadot and rococo Relay. I got the exact same results. When I run my custom branches with --alice and --bob everything works btw. It is kinda strange.
    – Zycon
    Oct 19, 2022 at 13:55
  • 2
    I tried adding the --discover-local tag and it didn't work unfortunately. Thank you @bkchr. I will try tomorrow the Zombienet and will let you know @Bruno. Thank you as well!
    – Zycon
    Oct 20, 2022 at 18:34
  • 1
    @Bruno Sorry for my super late reply. Was working on some other stuff. I tried Zombienet but I couldn't really reproduce the issue. I was expecting Zombienet to work because it uses --alice and --bob. I am still pretty confused of this issue... it doesn't make sense.
    – Zycon
    Nov 4, 2022 at 14:18

1 Answer 1


The question is answered here. Apparently there was a problem inserting the keys. After following all the steps of the solution, my parachain could produce and finalize blocks.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.