0

Followed the installation steps provided here

https://docs.substrate.io/tutorials/v3/create-your-first-substrate-chain/

Steps taken with node version v16.14.0

git clone https://github.com/substrate-developer-hub/substrate-front-end-template
yarn install

Error code

Resolution step
➤ YN0002: │ eslint-config-react-app@npm:7.0.0 [e199f] doesn't provide @babel/plugin-syntax-flow (p79568), requested by eslint-plugin-flowtype
➤ YN0002: │ eslint-config-react-app@npm:7.0.0 [e199f] doesn't provide @babel/plugin-transform-react-jsx (p2880e), requested by eslint-plugin-flowtype
➤ YN0002: │ react-dev-utils@npm:12.0.0 doesn't provide typescript (p08c91), requested by fork-ts-checker-webpack-plugin
➤ YN0002: │ react-dev-utils@npm:12.0.0 doesn't provide webpack (pf80ce), requested by fork-ts-checker-webpack-plugin
➤ YN0002: │ react-scripts@npm:5.0.0 [9c894] doesn't provide autoprefixer (peca2e), requested by tailwindcss
➤ YN0060: │ react-scripts@npm:5.0.0 [9c894] provides eslint (p3d1f2) with version 8.6.0, which doesn't satisfy what eslint-config-react-app and some of its descendants request
➤ YN0002: │ substrate-front-end-template@workspace:. doesn't provide eslint (p83184), requested by eslint-config-prettier
➤ YN0002: │ substrate-front-end-template@workspace:. doesn't provide webpack (p9e29f), requested by node-polyfill-webpack-plugin
➤ YN0000: │ Some peer dependencies are incorrectly met; run yarn explain peer-requirements <hash> for details, where <hash> is the six-letter p-prefixed code
➤ YN0000: └ Completed in 0s 245ms
➤ YN0000: ┌ Fetch step
➤ YN0013: │ semantic-ui-css@https://github.com/Semantic-Org/Semantic-UI-CSS.git#commit=01e4a5346496c284db3b19a102458731ccccd911 can't be found in the cache and will be fe
➤ YN0013: │ semantic-ui-css@https://github.com/Semantic-Org/Semantic-UI-CSS.git#commit=01e4a5346496c284db3b19a102458731ccccd911 can't be found in the cache and will be fe
➤ YN0018: │ semantic-ui-css@https://github.com/Semantic-Org/Semantic-UI-CSS.git#commit=01e4a5346496c284db3b19a102458731ccccd911: The remote archive doesn't match the expected checksum
➤ YN0000: └ Completed in 8s 74ms
➤ YN0000: Failed with errors in 8s 327ms

2 Answers 2

2

Resolved it by performing these steps

yarn cache clean --all
yarn install

At this point, got the same error. Then run this:

YARN_CHECKSUM_BEHAVIOR=update yarn

Credits to answer from Github discussion

1

I just tried it and had no issues. This was probably a temporary error with the git repository from Semantic-Org. Can you still replicate this?

1
  • Yea I experienced it but managed to resolve through the above
    – John
    Commented Feb 26, 2022 at 14:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.