0

I am trying to add evm_pallet with NPOS consensus( i.e babe and staking) but while adding evm_pallet to runtime getting error..

active toolchain

1.59-x86_64-unknown-linux-gnu (default)

rustc 1.59.0 (9d1b2106e 2022-02-23)

1 Answer 1

1

Looks like you are using some older Substrate version?

Nevertheless, it looks like you didn't enabled the std feature for evm_pallet when building for native. This should solve your problem.

2
  • I have tried to build using rust 1.63 but it still shows the error and i have added Evm_pallet std feature in cargo.toml Sep 19, 2022 at 9:58
  • Rust version is not related to this. Do you have a link to your runtime?
    – bkchr
    Sep 19, 2022 at 10:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.