0

We had changed the code in pallet template and was trying to add it in substrate node-template runtime. Link to [github code]2

Got the following error.

After answer updated following new error: error

Error - Compiling node-template-runtime v4.0.0-dev (/data/Network-marketing/runtime) error: failed to run custom build command for node-template-runtime v4.0.0-dev (/data/Network-marketing/runtime)

Caused by: process didn't exit successfully: /data/Network-marketing/target/release/build/node-template-runtime-55554732df6f82a1/build-script-build (exit status: 1) --- stdout Information that should be included in a bug report. Executing build command: "rustup" "run" "nightly" "cargo" "rustc" "--target=wasm32-unknown-unknown" "--manifest-path=/data/Network-marketing/target/release/wbuild/node-template-runtime/Cargo.toml" "--color=always" "--profile" "release" Using rustc version: rustc 1.65.0-nightly (02654a084 2022-08-30)

--- stderr Compiling node-template-runtime v4.0.0-dev (/data/Network-marketing/runtime) error[E0119]: conflicting implementations of trait core::convert::TryFrom<OriginCaller> for type frame_system::RawOrigin<[type error]> --> /data/Network-marketing/runtime/src/lib.rs:284:1 | 284 | construct_runtime!( | ^ | || | || 285 | || pub enum Runtime 286 | || where 287 | || Block = Block, ... || 302 | || } 303 | || ); | ||_- in this macro invocation ... | | = note: conflicting implementation in crate core: - impl<T, U> TryFrom for T where U: Into; = note: this error originates in the macro frame_support::construct_runtime which comes from the expansion of the macro construct_runtime (in Nightly builds, run with -Z macro-backtrace for more info)

For more information about this error, try rustc --explain E0119. error: could not compile node-template-runtime due to previous errorenter code here

3
  • 1
    I've just checked out the linked repo and it compiled without giving any errors. Have you tried running rustup update? Aug 31, 2022 at 13:20
  • yes I have tried rustup update... still not worked. Sep 1, 2022 at 5:44
  • Sorry, I uploaded the wrong the files. I've changed the files please check it now. Sep 1, 2022 at 6:34

1 Answer 1

2

The problem is this line in your custom pallet template:

pub use frame_system::pallet::*;

With this line, you have basically exported the entire frame_system Pallet into your file, which makes all of the pallet template imports look like frame system.

You should change this line to:

pub use pallet::*;

As seen here: https://github.com/substrate-developer-hub/substrate-node-template/blob/main/pallets/template/src/lib.rs#L6

I am interested to know how you got to this error, and what you were trying to do. Does some tutorial tell you to do this?

7
  • No I am doing this on my own. Basically, I am trying to build a simple network marketing pallet in which you can add different people. Its just a start. Sep 2, 2022 at 5:35
  • It is giving error after this also in the runtime. Now instead of 9 its giving just 1 runtime error. Sep 2, 2022 at 5:45
  • I've have uploaded the new error, kindly look into it. Sep 2, 2022 at 5:55
  • please open a new question, and do not put screenshots, but share the error as text.
    – Shawn Tabrizi
    Sep 2, 2022 at 8:49
  • I have uploaded the new code to the github link. I'll upload the errors. Sep 2, 2022 at 9:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.