1

When trying to run try-runtime I do not get any logs. I also received an error in my local node:

2022-07-28 14:42:57 Accepting new connection, 1/100
2022-07-28 14:42:57 WS error: i/o error: Transport endpoint is not connected (os error 107); terminate connection 14
2022-07-28 14:42:57 Accepting new connection, 1/100
2022-07-28 14:42:57 WS error: i/o error: Transport endpoint is not connected (os error 107); terminate connection 15

Output from try-runtime

RUST_LOG=runtime=trace,try-runtime::cli=trace,executor=trace cargo run --release --features=try-runtime try-runtime --execution Native on-runtime-upgrade live --uri ws://localhost:9944


    Finished release [optimized] target(s) in 1.32s
     Running `target/release/tfchain try-runtime --execution Native on-runtime-upgrade live --uri 'ws://localhost:9944'`

My node is on version polkadot-0.9.24, I also saw a similar issue here on stackexchange as well as on github (https://github.com/paritytech/substrate/issues/11691) But I am not sure how to fix the problem where I don't have any output logs.

Not sure if it's a related problem but when I run my node I also don't receive the output log what we used to have on substrate v3. It currently looks like this:

➜ ./target/debug/tfchain --dev --ws-external                                                                
2022-08-01 13:38:40 〽️ Prometheus exporter started at 127.0.0.1:9615    
2022-08-01 13:38:42 🙌 Starting consensus session on top of parent 0x4ffef2a81bdbb08f62e222fff128e5f69938b268117a1b81df76f06117f7dd8b    
2022-08-01 13:38:42 types::NodeContract billed successfully at block: 1    
2022-08-01 13:38:42 🎁 Prepared block for proposing at 1 (134 ms) [hash: 0x0679f9497911563cd0a7ee23b28334ab821175472b5541b0989dc23c334b775f; parent_hash: 0x4ffe…dd8b; extrinsics (1): [0xf713…8989]]    
2022-08-01 13:38:42 🔖 Pre-sealed block for proposal at 1. Hash now 0x847aa4d6dc62c808f2771c7de0eb6c2a815f662700f8bbd8522401648b3d04d8, previously 0x0679f9497911563cd0a7ee23b28334ab821175472b5541b0989dc23c334b775f.    
2022-08-01 13:38:42 ✨ Imported #1 (0x847a…04d8)    
2022-08-01 13:38:42 offchain worker done.    
2022-08-01 13:38:45 💤 Idle (0 peers), best: #1 (0x847a…04d8), finalized #0 (0x4ffe…dd8b), ⬇ 43 B/s ⬆ 0

1 Answer 1

2

As my comments is saying, you need to pin tracing-core to 0.1.26.

2
  • Thanks, I tried to pin this version in the runtime but that didn't compile. When I pin it in the node it works. Commented Aug 1, 2022 at 13:13
  • Yeah, the node is the one that is responsible for printing. So, pinning it there is the correct way :)
    – bkchr
    Commented Aug 1, 2022 at 13:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.