3

I'm trying to trigger the storage migration on polkadot UI for our parachain. I'm trying different types to do this but getting some issues:

Type 1 : If I simply upload the wasm file from sudo > setcode, then this is coming : enter image description here In this, On upper righthand blue proces will not complete.

Type 2 : I'm using scheduler pallet, But If I want to want to upload the runtime.compact.wasm this error is shown(Size of wasm is 4.6mb): enter image description here But If I upload this runtime.compact.compressed.wasm: enter image description here This error is shown: enter image description here

Type 3:

3
  • 3
    Looks like you're exhausting the block limit. You can use sudo_unchecked_weight with value 0 - "This setting allows for a block to take an indefinite time to compute to ensure that the runtime upgrade does not fail". Take a look at this tutorial: docs.substrate.io/tutorials/get-started/forkless-upgrade/…
    – Bruno
    Jul 11, 2022 at 19:41
  • 2
    Use compact.compressed WASM.
    – Bruno
    Jul 13, 2022 at 14:15
  • 1
    @Bruno Yeah, Issue is solved by using compact.compressed wasm. Thanks! Jul 13, 2022 at 19:16

2 Answers 2

2

You can try use compact.compressed.wasm instead of compact.wasm.

3

This is not the way to perform runtime upgrade on parachain.

Runtime upgrade process is different in solochain and parachain. Please refer this https://docs.substrate.io/reference/how-to-guides/parachains/upgrade-a-parachain/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.