2

We are trying to run the docker solution available for the substrate-node-template but are hitting a crash, only on M1 Macs.

To repro, from the substrate-node-template repository, we added

touch .local

to line 9 of ./scripts/docker_run.sh

and run:

./scripts/init.sh
./scripts/docker_run.sh

On the M1 Mac, it is crashing while updating crates.io index and the output is as follows:

MacBook-Pro ~/d/substrate-node-template (main)> ./scripts/docker_run.sh
*** Start Substrate node template ***
[+] Running 2/2
 ⠿ Container node-template                  Removed                                                                                                                                                              0.0s
 ⠿ Network substrate-node-template_default  Removed                                                                                                                                                              0.1s
[+] Running 1/0
 ⠿ Network substrate-node-template_default  Created                                                                                                                                                              0.0s
    Updating crates.io index
bash: line 1:     8 Killed                  cargo build --release   

We have tried upping the RAM and swap space available in Docker to 16GB and 4GB respectively and this still failed. We are able to run these commands successfully on non-M1 macs.

Is anyone aware of a solution for this compatibility issue?

1 Answer 1

3

That script is not compatible with Mac's.

It is compiled for Linux.

I ran into a similar conundrum recently:

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.