0

I tried the following:

  1. Download the latest substrate-node-template repository: https://github.com/substrate-developer-hub/substrate-node-template/tree/latest (I want the node template not the contract node)

  2. I tried the steps in document: https://docs.substrate.io/tutorials/work-with-pallets/contracts-pallet/

Findings: The documentation cause an error.

I added only the pallet_contracts and primitives then tried to run cargo build --release. I received an error as follows:

failed to select a version for the requirement

Please help.

My goal is to add a smart contract support to my substrate-node-template. Not any other template like node-contract, etc., since I already started hacking my template.

4
  • Thatnks for reporting, this should be reported on the docs site as an issue: github.com/substrate-developer-hub/substrate-docs/issues/…
    – Dan Shields
    Jun 24 at 4:00
  • In general, if following the steps on the docs doesn't work, is should be handled there, instead of posting that here. Customization for things based on docs that have issues, of couse can be asked here so we can help you grow past just what is instructed in the docs :)
    – Dan Shields
    Jun 24 at 4:01
  • I’m voting to close this question because this should be a docs fix.
    – Dan Shields
    Jun 24 at 4:02
  • Dan, where would it be handled? So how can we solve this issue, by fixing the docs? It sound strange.
    – hgminerva
    Jun 24 at 5:54

0

Browse other questions tagged or ask your own question.