After upgrading our chain and its relevant dependencies to polkadot-v0.9.22 I am getting the following build error for 'tikv-jemalloc-sys v0.4.3+5.2.1-patched.2' enter image description here

enter image description here

I have also tried to add parity-util-mem = { version = "0.11", default-features = false, features = ["jemalloc-global"] } as a dependency to our node's Cargo.toml file and it does not seem to solve the problem.

Here is my current rust configuration enter image description here I have tried applying the solutions suggested in Problem compiling substrate node in WSL ( windows ) and Error: failed to run custom build command for `tikv-jemalloc-sys v0.4.3+5.2.1-patched.2` but still seems to get the same error. Furthermore, the problem does not seem to occur on non-WSL machines

  • Just a quick test, can you compile the substrate-node-template?
    – Bruno
    Commented Jun 22, 2022 at 15:26
  • @bruno No, I get the same error as the one I mentioned in the post
    – chexware
    Commented Jun 22, 2022 at 16:46
  • I am assuming you have already ran sudo apt update, sudo apt install --assume-yes git clang curl libssl-dev llvm libudev-dev make protobuf-compiler, cargo clean, cargo build. Also, worth noting that there is a newer version of tikv-jemalloc-sys. You could try manually updating and see if that works.
    – Bruno
    Commented Jun 22, 2022 at 17:09
  • Yes, I am using the latest available version of all of my system libraries + the mentioned ones are installed too. I will try to manual update ` tikv-jemalloc-sys ` @bruno , thanks for the suggestion
    – chexware
    Commented Jun 22, 2022 at 18:31
  • Is this still an issue? Were you able to resolve it? If so, please share your answer.
    – Bruno
    Commented Aug 1, 2022 at 17:35

3 Answers 3


None of the given solutions worked for me.

Later when I had my whole directory in the WSL2 file system (instead of the windows file system like earlier) and tried the build command, it worked for me.


Got a similar issue when running builds on Ubuntu. Managed to resolve it by installing jemalloc via sudo apt install libjemalloc2


Try to use command: sudo make install


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.