1

I am running 4 collator nodes V1, V2, V3, and V4.

V2 and V3 look good and connected perfectly with V1. I am getting the below logs for V2 and V3.

Jun 20 16:44:40 testnet-2: 2022-06-20 16:44:40 [Relaychain] 💤 Idle (46 peers), best: #13214589 (0x7c36…37e2), finalized #13214585 (0x2836…f7ff), ⬇ 288.7kiB/s ⬆ 320.0kiB/s
Jun 20 16:44:42 testnet-2: 2022-06-20 16:44:42 [Relaychain] ✨ Imported #13214590 (0xfd88…e30b)
Jun 20 16:44:42 testnet-2: 2022-06-20 16:44:42 [Parachain] 💤 Idle (3 peers), best: #0 (0xeacd…ec21), finalized #0 (0xeacd…ec21), ⬇ 24 B/s ⬆ 24 B/s

But on V4, I am getting different logs. However, it has the same setup as V2 and V3

Jun 20 16:40:31 testnet-4: 2022-06-20 16:40:31 [Relaychain] ⚙️  Syncing 313.4 bps, target=#13214548 (48 peers), best: #96064 (0x4ea4…c54d), finalized #95744 (0x0456…d603), ⬇ 252.4kiB/s ⬆ 42.0kiB/s
Jun 20 16:40:32 testnet-4: 2022-06-20 16:40:32 [Relaychain] 💔 The bootnode you want to connect provided a different peer ID than the one you expect: `12D3KooWMVXPbqWRqwertySWDVPjcAQ9XtxqLTVzV4ccox9Y8KNL`.
Jun 20 16:40:35 testnet-4: 2022-06-20 16:40:35 [Parachain] 💤 Idle (3 peers), best: #0 (0xeacd…ec21), finalized #0 (0xeacd…ec21), ⬇ 58 B/s ⬆ 49 B/s
Jun 20 16:40:36 testnet-4: 2022-06-20 16:40:36 [Relaychain] ⚙️  Syncing  0.0 bps, target=#13214548 (48 peers), best: #96064 (0x4ea4…c54d), finalized #95744 (0x0456…d603), ⬇ 72.9kiB/s ⬆ 37.3kiB/s

Can someone please help me to fix this?

2

1 Answer 1

1

This issue was reported here: https://github.com/paritytech/substrate/issues/11709 and a fix has recently been merged into master here: https://github.com/paritytech/substrate/pull/11851

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.