0

I am trying to send assets from parachain to relaychain from polkadotXcm extrinsic reserveTransferAssets and teleportAssets in polkadotjs app, but it is giving me Asset Not Found error, I am not sure how to fix it, I have tried creating asset also from the UI and tried passing the asset ID in those extrinsic, but getting the same error.

Image showing extrinsic call in polkadotjs app

Block details

1 Answer 1

2

If I understand what you are doing correctly, then the Polkadot relay chain only knows about and supports the DOT token. So you cannot transfer other tokens to the relay chain, and as you have seen, the relay chain will reject those messages.

2
  • Thank you for the response @shawn. After creating an Asset in para chain, I was able to teleport it to relay chain, but on relay chain I am getting UntrustedTeleportLocation. Can you guide what could be the case here? Jun 8, 2022 at 11:37
  • XCM is not aware of the logic of both chains. You can absolutely initiate some XCM from parachain A, which will then be rejected by parachain B or even the relay chain. In this case, as I have mentioned, your Parachain is trying to move some asset to the relay chain, but the relay chain does not support that asset, nor does it trust your chain (an XCM configuration). Because of that, it will reject that XCM message.
    – Shawn Tabrizi
    Jun 9, 2022 at 10:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.