2

I forked the Substrate Stencil node to kickstart from Governance and Staking. I've followed the steps from both the repo and Substrate docs. I tried to run a staging node but it's idling with 4 validator peers.

Steps I've done;

  • Build a custom spec file with created keys.
  • Start the nodes
  • Insert keys to each node
  • Restart the nodes to see if it makes it any different

The commands I use can be found in this GitHub Gist.

I suspect that I'm doing something wrong with the keys but can't figure out what's that exactly.

2
  • This source is unmodified? What are your node logs?
    – Nuke
    Commented Jun 3, 2022 at 19:31
  • Yes, I just updated customSpec.json and created a new raw spec. Logs are just idling. I've managed to solve the issue. I knew It wasn't a good question but it worked as a totem :)
    – Burak
    Commented Jun 3, 2022 at 19:42

1 Answer 1

1

Found out that using derive when creating keys for authoring and finalization doesn't go well together.

What I've been doing:

./target/release/substrate-stencil key inspect --password-interactive --scheme Sr25519 "<secret>//1//babe"

./target/release/substrate-stencil key inspect --password-interactive --scheme Ed25519 "<secret>//1//grandpa"

What's working:

./target/release/substrate-stencil key generate --scheme Sr25519 --password-interactive

./target/release/substrate-stencil key inspect --password-interactive --scheme Ed25519 <secret-from-above>

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.