I have deployed my blockchain sometime ago and just checked that the era time is stuck, i have tried to forceNewEra() using sudo command, i have also tried forceNewEraAlways() but it changes the era time to 10 minutes. Than i tried to runtime upgrade the blockchian and it was upgraded successfully but era time was still not updated. Some please help me asap.

enter image description here

  • If you can include a WS address and a Github repo that would be great!
    – Bruno
    May 27, 2022 at 16:55
  • @Bruno it is not possible to me to share github repo can you please give some idea that how can i correct this or where i have to change. Thanks in advance.... May 31, 2022 at 7:26
  • Have you made add some custom logic around eras ? Something that we cannot know how it could be affecting the system without checking the code ? Is it possible for you to share some description on how your system is architected ? I feel that something like that should not happen without modifications to certain parts of the codebase. Jul 4, 2022 at 14:44
  • This may be the issue: github.com/polkadot-js/apps/issues/7607#issuecomment-1129752912
    – Bruno
    Jul 4, 2022 at 18:28
  • @AlejandroMartínez we haven't done any changes around eras but we did some changes in fee structure, i think that would not be a problem, we just increased the validator count from 10 -> 12 using sudo. Jul 5, 2022 at 4:54

1 Answer 1


As stated here: https://github.com/polkadot-js/apps/issues/7607#issuecomment-1129752912

This situation can happen IFF the chain moves to an emergency condition where the election/staking have failed to trigger a new era. In this case, new sessions are created, but no new era is created, thus no new validator set is also chosen and we stick with the old set.

This is why the duration of the era is prolonged.

A fix is also proposed within that link.

  • I have tired all these solutions but still the problem persists, I don't have governance_fallback function in my code, so don't know if it will work or not, I tried set_emergency_election_result function it didn't worked. Is there any other way to solve this? Jul 6, 2022 at 6:20
  • Have you generated the appropriate supports using staking-miner ? Jul 7, 2022 at 7:44
  • @AlejandroMartínez it is same as provided by the substrate, we didn't change anything in it. Jul 7, 2022 at 10:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.