2

I am following the tutorial on substrate playground, and when I run the cargo check, I get the following compilation error:

 error: failed to select a version for `impl-trait-for-tuples`.
    ... required by package `frame-support v4.0.0-dev (https://github.com/paritytech/substrate.git?branch=polkadot-v0.9.20#563f4820)`
    ... which satisfies git dependency `frame-support` of package `pallet-nicks v4.0.0-dev (https://github.com/paritytech/substrate.git?branch=polkadot-v0.9.20#563f4820)`
    ... which satisfies git dependency `pallet-nicks` of package `node-template-runtime v4.0.0-dev (/home/playground/workspace/runtime)`
    ... which satisfies path dependency `node-template-runtime` (locked to 4.0.0-dev) of package `node-template v4.0.0-dev (/home/playground/workspace/node)`
versions that meet the requirements `^0.2.2` are: 0.2.2

all possible versions conflict with previously selected packages.

  previously selected package `impl-trait-for-tuples v0.2.1`
    ... which satisfies dependency `impl-trait-for-tuples = "^0.2.1"` (locked to 0.2.1) of package `frame-support v4.0.0-dev (https://github.com/paritytech/substrate.git?tag=devhub/latest#e6fbbd5c)`
    ... which satisfies git dependency `frame-support` (locked to 4.0.0-dev) of package `frame-benchmarking v4.0.0-dev (https://github.com/paritytech/substrate.git?tag=devhub/latest#e6fbbd5c)`
    ... which satisfies git dependency `frame-benchmarking` (locked to 4.0.0-dev) of package `frame-benchmarking-cli v4.0.0-dev (https://github.com/paritytech/substrate.git?tag=devhub/latest#e6fbbd5c)`
    ... which satisfies git dependency `frame-benchmarking-cli` (locked to 4.0.0-dev) of package `node-template v4.0.0-dev (/home/playground/workspace/node)`

failed to select a version for `impl-trait-for-tuples` which could resolve this conflict how to solve this issue?
1
  • Your issue is on cargo.toml and can you try to clean cache ( cargo clean). If it doesnt work try to check careful your dependecies May 17, 2022 at 14:21

1 Answer 1

1

I just ran the substrate playground and the version that is in the Cargo.lock file is:

[[package]]
name = "impl-trait-for-tuples"
version = "0.2.2"
source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "11d7a9f6330b71fea57921c9b61c47ee6e84f72d394754eff6163ae67e7395eb"
dependencies = [
 "proc-macro2",
 "quote",
 "syn",
]

If you're still running into this issue, delete your Cargo.lock file and re-run cargo build.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.