0

I'm trying to add the feature of metadata hashing on my chain which is updated to Polkadot SDK 1.6 but cargo fails configure:

    Updating crates.io index
error: failed to select a version for `sp-api-proc-macro`.
    ... required by package `sp-api v26.0.0`
    ... which satisfies dependency `sp-api = "^26.0.0"` of package `nodle-parachain v2.5.3 (/home/simson/nodle/chain/node)`
versions that meet the requirements `^15.0.0` are: 15.0.1

the package `sp-api` depends on `sp-api-proc-macro`, with features: `frame-metadata` but `sp-api-proc-macro` does not have these features.


failed to select a version for `sp-api-proc-macro` which could resolve this conflict

looking at https://crates.io/crates/sp-api-proc-macro/versions I can see version 15 is yanked.

What workaround would solve this problem?

update

Bkchr committed this f00a911c52c047db3119dedfddc86c332ff6626b to branch release-polkadot-v1.6.0 yesterday will this be released on crates.io soon to solve this problem?

0

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.