0

I'm running a polkadot-js/apps instance here with the following command:

docker run -it --name polkadot-ui -e WS_URL=<NODE_URL> -p 80:80 jacogr/polkadot-js-apps:latest

The web UI is being served and the browser can load it. But the app tries to connect to ws://127.0.0.1:9944 instead of the provided <NODE_URL>.

This seems to be the place where the URL is resolved.

There are some interaction with the packages @polkadot/apps-config and @polkadot/ui-settings (which is in another repo).

How can I set the default endpoint for the websocket/RPC url on the frontend?

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.